WordPress.org

Ready to get started?Download WordPress

Forums

IOSEC HTTP Anti Flood/DoS Security Gateway Module
[resolved] [Plugin: IOSEC HTTP Anti Flood Security Gateway Module] Cannot modify header information (6 posts)

  1. chevymanusa
    Member
    Posted 2 years ago #

    I get this error on two different pages (so far). These errors occur are possibly related to an conflict with S2Member?
    S2member protected page:

    Warning: Cannot modify header information - headers already sent by (output started at /public_html/wp-data/plugins/iosec-anti-flood-security-gateway-module/iosec.php:1) in /public_html/wp-includes/pluggable.php on line 866
    Only this error is shown, nothing else.

    Log in page at the top:
    Warning: Cannot modify header information - headers already sent by (output started at /public_html/wp-data/plugins/iosec-anti-flood-security-gateway-module/iosec.php:1) in /home/planetsi/public_html/wp-login.php on line 349

    Warning: Cannot modify header information - headers already sent by (output started at /public_html/wp-data/plugins/iosec-anti-flood-security-gateway-module/iosec.php:1) in /home/planetsi/public_html/wp-login.php on line 361

    The login info boxes are still present just showing the error at the top.

    Post here or PM if you need more info.
    Chevymanusa @ gmail.com
    I currently have the plugin disabled until I can get it working with no errors. I did like what I saw!

    http://wordpress.org/extend/plugins/iosec-anti-flood-security-gateway-module/

  2. MickeyRoush
    Member
    Posted 2 years ago #

    @chevymanusa

    Please read what I posted here:

    http://wordpress.org/support/topic/plugin-iosec-http-anti-flood-security-gateway-module-error-message-when-activating-plugin-version-141?replies=2

    It seems as though the plugin author saved the file with the incorrect encoding. With Notepad++ save the file as either ANSI or UTF-8 without BOM. Make sure it's without BOM.

  3. chevymanusa
    Member
    Posted 2 years ago #

    @mickey
    Thanks for the quick reply. I do not see the option to save it as either ANSI or UTF-8 w/o BOM. Could you provide more information on how to address this. What files should I encode?

    Thanks in advance for your help!

    Regards,
    Chevyman

  4. MickeyRoush
    Member
    Posted 2 years ago #

    @chevymanusa

    I'm not sure how you've installed the plugin. But you're going to have to edit the iosec.php file in Notepad++ or another text editor on your workstation.

    So download the plugin to your desktop. Unzip. Open iosec.php in Notepad++. Go to Encoding. Select either "Encode in ANSI" or "Encode in UTF-8 without BOM". Then save. Then FTP the file or the whole plugin to your plugins directory via FTP/SFTP or other client.

    The plugin author needs to do this with the file in the WordPress Repository so that no one else has any problems when they download the original from WordPress. But I'm not sure if he/she even ventures to the support forum.

  5. iosec
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the delay. This issue is fixed now. You can remove and install your plugin to get over this issue.

    Thank you.

  6. chevymanusa
    Member
    Posted 2 years ago #

    @Mickey Thanks for the information and help it worked out. Now I know how to encode via notepad++.

    @iosec, Thank you for your response and for correcting the issues in plugin. Nice work all the way around!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.