WordPress.org

Ready to get started?Download WordPress

Forums

Invite Friends to Register
Backslashes in Email Message in settings (2 posts)

  1. gurubobnz
    Member
    Posted 1 year ago #

    Hi,

    Nice plugin, suits very well for our WordPress usage. Version 0.2 appears (at least on our installation) to be saving escaped quotes into the database. See here: http://i.imgur.com/ukYBO.png and also this:

    mysql> select option_value from wp_options where option_name = 'invfr_settings' \G
    *************************** 1. row ***************************
    option_value: a:3:{s:7:"subject";s:53:"Your friend has invited you to register at %sitename%";s:7:"message";s:295:"Dear %friendname%,
    
    I\'d love to share my family diary and random parenting thoughts with you if you\'re interested. Most of my posts are available to registered users only.
    
    To register as a member of my blog at %sitename% follow this link to register now: %inviteurl%
    
    Cheers,
    - Linda -";s:8:"redirect";s:45:"http://mummy.guru.net.nz/wp-admin/profile.php";}
    1 row in set (0.00 sec)

    I've temporarily fixed this (in the wrong place) by putting this in sendmail.php: $message = stripslashes( $message ); which of course just removes the slashes when the invite message is sent.

    I'm not familiar with WordPress plugins so had difficulty following the plugin architecture to find what was responsible for saving the values like this.

    Can you comment on this? All magic_quotes settings are Off on the server.

    Cheers,

    - Bob -

    http://wordpress.org/extend/plugins/invite-friends-to-register/

  2. Tammy Hart
    Member
    Plugin Author

    Posted 1 year ago #

    This will be fixed in version 0.3 which I'm pushing today.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.