WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: IntenseDebate Comments] Bad URL for 'loading.gif' (4 posts)

  1. evanw
    Member
    Posted 5 years ago #

    The IntenseDebate plugin currently has a bad URL for the image 'loading.gif'.

    It is attempting to load it from: http://www.yoursite.com/article-id/wp-content/plugins/intensedebate/loading.gif - which does not exist.

    In our case, it's trying to load: http://www.techerator.com/2009/08/essential-addons-for-firefox-1-power-user-edition/wp-content/plugins/intensedebate/loading.gif

    Thanks for any help you can provide.

  2. evanw
    Member
    Posted 5 years ago #

    In the IntenseDebate plugin folder, the suspect file is intensedebate-comment-template.php

    Specifically line 33:
    <img src='<?php echo str_replace( trailingslashit( get_bloginfo( 'wpurl' ) ), '', WP_PLUGIN_URL ); ?>/intensedebate/loading.gif' alt='Loading' border='0' align='absmiddle' />

  3. Beau Lebens
    Member
    Posted 5 years ago #

    Hi evan, thanks. We've actually fixed this in the development version, but haven't released yet because we don't want to force people to update just for that. You can manually fix that line by replacing the whole line with this if you like:

    idc_ld.innerHTML = "<img src='<?php echo WP_PLUGIN_URL; ?>/intensedebate/loading.gif' alt='Loading' border='0' align='absmiddle' /> <?php _e( 'Loading IntenseDebate Comments...', 'intensedebate' ); ?>";

  4. evanw
    Member
    Posted 5 years ago #

    Thanks! Looking forward to the new release (and Twitter and Facebook Connect support is great!)

Topic Closed

This topic has been closed to new replies.

About this Topic