WordPress.org

Ready to get started?Download WordPress

Forums

Instapress
[resolved] Pagination not working? (20 posts)

  1. doorsixteen
    Member
    Posted 2 years ago #

    I LOVE this plugin, and I'm really happy to try it out, but I'm having a couple of problems that I can't seem to resolve.

    The first is that by following the styling guidelines in the plugin FAQ, I cannot get the thumbnails in my Instapress gallery to display at the size I've chosen—they display at 150px. I'd like them to display at 140px so that a row of 4 will fit across in my content column. You can see my in-progress gallery here:
    http://www.doorsixteen.com/instagram/

    This is the CSS I tried, per the FAQ (as well as setting the size in the shortcode):

    .instagram-image img {
    width: 140px !important;
    height: 140px !important;
    }

    Interestingly, the code output indicates that the image height and width are set to 140px, but they are actually displaying at 150px.

    The only way I'm able to get the images to display at 140px is by adding the following:

    .fancybox img {
    width: 140px !important;
    height: 140px !important;
    }

    This works, but it's counter to the FAQ.

    The other issue I'm having is with the pagination. It doesn't work for me! I have it spec'd to be active in the shortcode, but the link that's output just leads to my homepage. Any suggestions?

    Also, this isn't related to my site, but I did notice that the demo page is throwing a 403 error:
    http://demo.instapress.it/

    http://wordpress.org/extend/plugins/instapress/

  2. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    unfortunately there's a problem with our demo site and we are working on it.

    According your styling issue:
    There's a section to style Instapress widget and a section to style Instapress shortcode in the FAQ. So according to the FAQ you can e.g. change the images' appearance like this:

    .instapress-shortcode img {
        height: 140px !important;
        width: 140px !important;
    }

    According your pagination issue:
    This sound like a Javascript error to me. Could you please check if there's any error output in your browser after clicking "Next" in Instapress gallery?

    Hope we'll find a solution soon. Thanks.

  3. doorsixteen
    Member
    Posted 2 years ago #

    Hello! Thank you so much for replying.

    The styling issue is now resolved. Perfect!

    I've gone ahead and added pagination back in so you can see the page output. There's no Javascript error showing up for me.
    Here's the page:
    http://www.doorsixteen.com/instagram/

    As you can see, the "next" link simply points back to the home page. I've looked at a few other Instapress galleries on other sites to compare, and it seems they all have the same problem I do.

    My shortcode looks like this:
    [instapress userid="self" piccount="64" effect="fancybox" paging="1" title="1" size="140"]

    Any idea what the issue could be? I'd love to get the pagination working if possible...that's a great feature!

  4. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    did you probably disable all effects in Instapress' settings in wp-admin? That might cause your issue. Please check that so I can have a close look into that.

    Thanks.

  5. doorsixteen
    Member
    Posted 2 years ago #

    Yes, I did have the box checked to disable effects. I've un-checked it now, but the result is the same. I'll leave it un-checked so you can take a look, though!

  6. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    That's strange. Are you probably using any caching plugins?
    Do you use a custom template? If so, does that template include scripts that were added by wp_enqueue_script ?

    The problem is, that your page does not include the necessary file instapress.js and I can't see why. :(

  7. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Another thing that could cause that issue is the fancybox plugin you are using. Would be worth a try disabling that to double check that.

    Thanks.

  8. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Another thing that just came to my mind:
    Are you using wp_footer() in your template?

  9. doorsixteen
    Member
    Posted 2 years ago #

    No, I don't use any caching plugins.

    Yes, my theme is custom, but I have not used wp_enqueue_script to add any scripts.

    I just tried disabling the Easy Fancybox plugin, but that did not make any difference. (I've turned it back on now, since that does not seem to be the source of the problem.)

    And yes, I have wp_footer() in my template above the </body> tag.

  10. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, I really can't figure out what the cause of your issue is.
    Would you be so kind as to try to add the following line to your template before wp_head() and wp_footer() are called:
    wp_enqueue_script('instapress', plugins_url('/instapress.js', $_SERVER['DOCUMENT_ROOT'].'wp-content/plugins/instapress/instagram.php'), array('jquery', 'sack'), InstagramPlugin::getVersion(), true);

    I hope we'll find a solution. Thanks.

  11. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    By the way: Did you have Instapress effects enabled when you disabled the fancybox plugin? Cause either way, the gallery won't work with effects disabled (we'll fix that in our next release).

  12. doorsixteen
    Member
    Posted 2 years ago #

    OK, I added the line...no luck!

    And yes, Instapress effects were enabled when I disabled the plugin.

    I'm happy to try anything else that you think might make a difference! It's still a great plugin even without the pagination, I just wish I could figure out why it's not working. ;)

    Do you have a link to an example of a gallery with the pagination working? The few sites I found all seemed to have the same problem that I'm having.

  13. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Is that line of code from above still in your template? The only thing I can think about now is that there's a problem with any of the dependencies for Instapress' javascript. Could you try modifying the code like that:
    wp_enqueue_script('instapress', plugins_url('/instapress.js', $_SERVER['DOCUMENT_ROOT'].'wp-content/plugins/instapress/instagram.php'), array('jquery'), InstagramPlugin::getVersion(), true);

    Here's a working example: http://knieh.com/?page_id=163

  14. doorsixteen
    Member
    Posted 2 years ago #

    I just changed the code (it's still in place)...again, no luck.

    Thanks for the link. It's helpful for me to see how it's supposed to function! I'll take a closer look tonight and see if I can figure out what the problem is.

    Thank you for all of your help!

  15. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, the only thing I can think about is that there has to be a problem with wp_enqueue_script. I'd advise you to probably changing the parameters and check if that changes anything.
    You could probably try:
    wp_enqueue_script('instapress', plugins_url('/instapress.js', $_SERVER['DOCUMENT_ROOT'].'wp-content/plugins/instapress/instagram.php'), array(), InstagramPlugin::getVersion(), true);
    as well as:
    wp_enqueue_script('instapress', plugins_url('/instapress.js', $_SERVER['DOCUMENT_ROOT'].'wp-content/plugins/instapress/instagram.php'), array(), '1.0', true);
    or:
    wp_enqueue_script('instapress-test', plugins_url('/instapress.js', $_SERVER['DOCUMENT_ROOT'].'wp-content/plugins/instapress/instagram.php'), array(), '1.0', true);

    This should result in a javascript error:
    wp_enqueue_script('instapress1', plugins_url('/instapress1.js', $_SERVER['DOCUMENT_ROOT'].'wp-content/plugins/instapress/instagram.php'));

    Please keep me up to date. Thanks.

  16. Jürgen Liechtenecker
    Member
    Plugin Author

    Posted 2 years ago #

    And a way that defintely has to work, but definetely is not the most beautiful, would be to add the following line after wp_footer():

    <script type="text/javascript" src="<?php echo trailingslashit(get_bloginfo( 'wpurl' )); ?>wp-content/plugins/instapress/instapress.js"></script>

  17. flavorjunction
    Member
    Posted 2 years ago #

    I know that this thread is set as 'resolved,' but I have started having an issue today that is related to the post.

    I just updated to 3.3.1 earlier this week.

    Upon pressing 'Next' in the Instapress paging, my site refreshes itself and the next page is not viewed.

    I do have Hypercache activated. Would this cause issues with the paging?

    There are wp_enqueue lines in my theme but the paging worked before today when I had Hypercache and 3.3.1 installed.

    Should I start a new thread?

  18. vickistep
    Member
    Posted 2 years ago #

    Same trouble. The "Next" link it just taking me to my homepage as you can see here http://www.joelwoodman.com/photo-blog/. I tried disabling any effects but no luck. Also tried adding that last script that you shared into my footer.php theme file just under wp_footer and above </body> but nothing changed.

  19. mruberto
    Member
    Posted 2 years ago #

    I can't get the plugin to display. Using 3.3.1. When I enter the instagram username and p/w and hit save, it disappears. I delete the cache but that doesn't make a difference. Help?

  20. handhugsdesign
    Member
    Posted 2 years ago #

    I am having the same trouble - when I add the script to my footer.php file, I get a spinning loading circle and a pop up window that never does anything when I click Next, but otherwise it just takes me to the home page. I cannot use fancybox, and have implemented a colorbox workaround for the image pop-outs, but I still need the pagination to work - is there a way that doesn't use ajax or something??

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags