WordPress.org

Ready to get started?Download WordPress

Forums

Plugin Installer Bugs (25 posts)

  1. tenetcommunity
    Member
    Posted 5 years ago #

    When trying to install cForms (an untested on 2.7 beta 2 plugin) i received the following error:
    Installing Plugin: cformsII - contact form 9.1

    Downloading plugin package from http://downloads.wordpress.org/plugin/cforms.9.1.zip

    Unpacking the plugin package

    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/tenetcom/public_html/installeddesign.com/wwwdev/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/tenetcom/public_html/installeddesign.com/wwwdev/wp-admin/includes/class-pclzip.php on line 5498

    Figured this would help...I can probably fix it, but I'd rather not have to hack into it, let you guys do the dirty work...keep it up, the platform is great, I love it

  2. smartbrain
    Member
    Posted 5 years ago #

    Hi to everybody,

    I've almost the same problem, but when I'm trying to install a new module, I get a message that says: "Could not create directory".

    Could you explain me why this errors occours? Because the core update runs without problems.

    I'm using wp 2.7-beta2-9559

    Thank you in advance

  3. OperaManiac
    Member
    Posted 5 years ago #

    yeah plugin installation has stopped working here as well...

    since it is using FTP i dont think i need to change any folder permissions!

  4. Actually, you may need to change folder permissions to allow the new folder to be created. I haven't used it yet.

  5. jpaonline
    Member
    Posted 5 years ago #

    I have the same thing the problem is this:

    An Unexpected HTTP Error occured during the API request.

    Try again

    Please get me some help here.

  6. RoarinRow
    Member
    Posted 5 years ago #

    I get this same problem with WP 2.7 when trying to click on 'Featured' plugins

    An Unexpected HTTP Error occured during the API request.

  7. go_big
    Member
    Posted 5 years ago #

    This is what I'm getting:
    Fatal error: Cannot redeclare class pclzip in /home/content/s/c/r/scrrweb/html/wp-admin/includes/class-pclzip.php on line 171

    any ideas?

  8. go_big
    Member
    Posted 5 years ago #

    actually found you need to deactivate wordpress automatic updater and all works fine. Check this link:
    http://wordpress.org/support/topic/224102?replies=34

  9. AmyCelona
    Member
    Posted 5 years ago #

    Okay, if I don't have WP automatic updater installed... why would it still happen?

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Do you have any other plugins that do automatic installs of anything? If so, then deactivate/remove them.

  11. AmyCelona
    Member
    Posted 5 years ago #

    I have:
    Akismet
    All-In-1 SEO
    Dean's FCKeditor
    Dean's Permalink Migrations
    Feedburner Feed replacement
    Get recent comments
    Nexgen Gallery (latest version for 2.7)
    Sociable (needs updating, can't click 'upgrade automatically' it fails)
    Twitter tools
    Wordpress.com stats
    WP Super cache (added yesterday, after the problem was already established).

    I manage 10 other sites, most have only 5 or so same plugins as me (Akismet, WPstats, FCKeditor, Get Recent Comments, Sociable) and they don't update either.

    If I turn them all off, I get the same results:

    Go to Install Plugins, I click on "Featured" and get 'An Unexpected HTTP Error occured during the API request' and when I click Try Again, I get the same.

    When I click Recently updated, I do get a list. when I click Install, I get same error 'An Unexpected HTTP Error occured during the API request'

    This is the same for all the sites, is it something my host company needs to change (or a setting I need to fix).

    Even the regular 'upgrade now' that usually works in the plugin list isn't working anymore.

    I appreciate your response!

  12. AmyCelona
    Member
    Posted 5 years ago #

    Update... just turned all plugins back on and tried again to to 'upgrade automatically' on sociable and got the error:

    Downloading update from http://downloads.wordpress.org/plugin/sociable.2.9.15.zip

    Download failed.: Operation timed out after 30000 milliseconds with 0 bytes received

    Plugin upgrade Failed

  13. AmyCelona
    Member
    Posted 5 years ago #

    Update again... for some crazy reason I tried to upgrade a plugin via the 'autoupgrade' option again and it worked.

    I have changed nothing, but maybe it is a memory cache issue?

  14. ucero
    Member
    Posted 5 years ago #

    Using WordPress 2.7, but is not installed in the root. Until last night it worked perfectly. Now, when an update plugin, I appear error "An Unexpected HTTP Error occurred during the API request." Do not go any automatic updating. I tried everything, including a new update to WordPress 2.7. The error left and no idea who is solving. Please help me. Thanks!

  15. GreenChange.TV
    Member
    Posted 5 years ago #

    1. Installing a plugin yields:
    An Unexpected HTTP Error occured during the API request.
    (seems occured is misspelled as well; occurred {chuckle})

    2. Seems WP automatic updater not installed via Fantastico..
    No plugins installed, at all…

    3. Also, when installing to a non-root dir, be careful to eliminate the directory prompt of "\"- I deleted all & re-installed after many bugs popped forth from an entry of "\blog" created
    http://mysite.com//blog/ (note the double // before blog)

    4. This host is using:VistaPanel Version 2.2.0 Beta
    Operating system Linux
    Apache version 2.2.10 (Unix)
    PHP version 5.2.6
    MySQL version 5.0.51
    The panel prevents from creating another db user acct
    MySQL external access - No

    5. http://wordpress.org/support/topic/215527
    6. http://www.110mb.com/forum/wordpress-built-in-plugin-explorer-non-functioning-t39588.0.html
    -poster hadn't tried 2.7 yet, but their guess was no fsockopen support

    7. Perhaps I'm missing a nuance of wording here?
    Fsocket functions Enabled
    but
    disable_functions exec,system,passthru,shell_exec,escapeshellarg,escapeshellcmd,proc_close,p

    roc_open,ini_alter,dl,popen,popen,pcntl_exec,socket_accept,socket_bind,socket_clear_error,socket_close,socket_connect,socket_create_listen,socket_create_pair,socket_create,socket_get_option,socket_getpeername,socket_getsockname,socket_last_error,socket_listen,socket_read,socket_recv,socket_revfrom,socket_select,socket_send,socket_sendto,socket_set_block,socket_set_nonblock,socket_set_option,socket_shutdown,socket_strerror,socket_write,stream_socket_client,stream_socket_server,
    pfsockopen,stream_set_timeout,disk_total_space,disk_free_space,chown,diskfreespace,getrusage,get_current_user,set_time_limit,getmyuid,getmypid,dl,leak,listen,chgrp,link,symlink,dlopen,proc_nice,proc_get_stats,proc_terminate,shell_exec,sh2_exec,posix_getpwuid,posix_getgrgid,posix_kill,ini_restore,mkfifo,dbmopen,dbase_open,filepro,filepro_rowcount,posix_mkfifo,putenv,sleep exec,system,passthru,shell_exec,escapeshellarg,escapeshellcmd,proc_close,proc_open,ini_alter,dl,popen,popen,pcntl_exec,socket_accept,socket_bind,socket_clear_error,socket_close,socket_connect,socket_create_listen,socket_create_pair,socket_create,socket_get_option,socket_getpeername,socket_getsockname,socket_last_error,socket_listen,socket_read,socket_recv,socket_recvfrom,socket_select,socket_send,socket_sendto,socket_set_block,socket_set_nonblock,socket_set_option,socket_shutdown,socket_strerror,socket_write,stream_socket_client,stream_socket_server,
    pfsockopen,stream_set_timeout,disk_total_space,disk_free_space,chown,diskfreespace,getrusage,get_current_user,set_time_limit,getmyuid,getmypid,dl,leak,listen,chgrp,link,symlink,dlopen,proc_nice,proc_get_stats,proc_terminate,shell_exec,sh2_exec,posix_getpwuid,posix_getgrgid,posix_kill,ini_restore,mkfifo,dbmopen,dbase_open,filepro,filepro_rowcount,posix_mkfifo,putenv,sleep display_errors Off Off

  16. AlexS66
    Member
    Posted 5 years ago #

    It seems no such problem In wp 2.7.1.
    ---
    http://www.webhostingr.net/

  17. jacobbrett
    Member
    Posted 5 years ago #

    I suddenly have this problem too, I don't and never had 'WP Automatic Updater'. The feeds on my dashboard aren't updating anymore (planet.wordpress.org and the dev blog) and my website's feed no longer shows up in an external rss reader on MySpace. Using WordPress 2.7.1.

  18. bbpc
    Member
    Posted 5 years ago #

    טכנאי מחשבים עד הבית
    לתיקון המחשב באופן יסודי

  19. m_itai
    Member
    Posted 5 years ago #

  20. ComPilots
    Member
    Posted 5 years ago #

    קומפיילוטס - טכנאי מחשבים אמין ומקצועי עוד היום אצלך בבית או בעסק!

  21. pcsup2000
    Member
    Posted 5 years ago #

    I have the same problem...Fatal error: Cannot redeclare pclziputilpathreduction() ...
    i tried twice and it is working now!

    Thanks,
    David, טכנאי מחשבים

  22. paripatel123
    Member
    Posted 4 years ago #

    I have the same problem, see below:

    I have the same thing the problem is this:

    An Unexpected HTTP Error occured during the API request.

    Try again

    Please get me some help here.

    It is advisable to stop automatic updates until this issue is resolved?

    Regards. Pari.

    ear plugs

  23. zairul
    Member
    Posted 4 years ago #

    The solution for this problem are already posted here;

    http://wordpress.org/support/topic/227430

  24. scyfox
    Member
    Posted 4 years ago #

    Hello.

    Today i had the same issue with 2.8.4

    But it was only a misconfiguration in the "General Options" Menu.

    I had to add a forwardslash (/) to the end of the WORDPRESS URL.

    THat went well.

    (figures) :P

    Silla!

  25. Choto Cheeta
    Member
    Posted 4 years ago #

    Well just faced the problem and did some reading via google regarding it..

    I think its because of the Web hosting's Internet running slow.. Waited for few mins and things started to work again..

    For reference please read, http://wordpress.org/support/topic/227430?replies=13

Topic Closed

This topic has been closed to new replies.

About this Topic