WordPress.org

Ready to get started?Download WordPress

Forums

WP Customer Reviews
Plugin inserts vCard into the_content, EVERYWHERE. (5 posts)

  1. djpeanut
    Member
    Posted 8 months ago #

    I've been wondering why my user profile's website, location and email address are showing up all over the place since I updated this plugin.

    Closer inspection reveals that WPCR seems to be injecting vCard markup into every call of the_content().

    Here's the offending markup that's appearing where it shouldn't be:

    <div id="wpcr_respond_1"><div id="wpcr_hcard_h" class="vcard"><a class="url fn org" href="http://yyyyy.loc/">Yyyyy</a><br><span class="adr"><span class="country-name">USA</span>&nbsp;</span><a class="email" href="mailto:xxxxxxxxxxx@gmail.com">xxxxxxxxxxx@gmail.com</a></div></div>

    This includes, worryingly, order emails sent to customers via WooCommerce!

    Please could you look into this?

    http://wordpress.org/plugins/wp-customer-reviews/

  2. Campbell McArthur
    Member
    Posted 7 months ago #

    This is my main beef with this plugin is that, not only does this plugin inject java script and it's own style sheet on every single Page /Post but even when you disable the VCARD from showing on every page it STILL continues to insert the HTML Below regardless!

    <div id="wpcr_respond_1"></div> </div>
    </div>

    So, not only do we have additional calls to Java Script and CSS style sheets that we DO NOT need on every single page but we also have to incur an additional penalty stroke with added USELESS HTML Markup that has no rhyme or reason to be there!

  3. Campbell McArthur
    Member
    Posted 7 months ago #

    Yeah and seriously.....where the hell are the developers of this plugin?

    I wrote the developer an email explaining this situation over a month and a half ago and have yet to receive a reply back or even the decency of a hello thank you for reporting the issue.....WTF???

  4. aashishbhargav
    Member
    Posted 5 months ago #

    I have the same issue. http://www.aureo.in . The home page has no text. I dont want any text to be shown, just background images. But because of the following content the home page text container loads.

    <div id="wpcr_respond_1"><div id="wpcr_hcard_h" class="vcard">Aureo
    <span class="adr"><span class="country-name">USA</span> </span>aash%%%%%il.com</div></div>

  5. aashishbhargav
    Member
    Posted 5 months ago #

    same issue.

Reply

You must log in to post.

About this Plugin

About this Topic