WordPress.org

Ready to get started?Download WordPress

Forums

Infinite-Scroll
[Plugin: Infinite Scroll] pathParse domain name /page/ added to the source code, bots will try to in (9 posts)

  1. jeriksson
    Member
    Posted 2 years ago #

    Hi,

    I recently added Infinite Scroll to my website, however i've noticed that the source code outputs something like this: pathParse :["http://mydomain-com/page/", "/"]

    The issue is that google thinks that the url in the source code http://mydomain-com/page/ exists and tries to crawl it on each page, which results in a massive amount of 404 pages.

    Is there anyway to could disable google from crawling the /page/ but still crawl /page/*.number/?

    Perhaps something with the robots or htaccess redirect?

    Thank you.

    http://wordpress.org/extend/plugins/infinite-scroll/

  2. jeriksson
    Member
    Posted 2 years ago #

    Hello again, would this perhaps stop search engines from attempting to reach /page/ yet reach /page/*/?

    Disallow: /tag/*/page/
    Allow: /tag/*/page/*/
    Disallow: /category/*/page/
    Allow: /category/*/page/*/

    Anyone got an idea? I've added this but i'm unsure if it actually works as i want it to.

    Thanks!

  3. beaver6813
    Member
    Plugin Author

    Posted 2 years ago #

    Whoa, thats really odd, so Google finds that URL in the Javascript source code and tries to crawl it?
    You could try this release candidate:
    http://downloads.wordpress.org/plugin/infinite-scroll.2.0b.110822RC1.zip
    (Just overwrite your existing plugin).

    That version puts the init code into an external javascript file so Google may ignore it :) Let me know how it goes (or if your htaccess method worked!)

  4. jeriksson
    Member
    Posted 2 years ago #

    Yes, google is following the link from the source.

    I updated to the version you recommended and indeed there is no link in the source of the page now and google should now crawl js files to find it i'm guessing.

    However this version breaks when using wp-minify on html code, i'm guessing it has something to do with the :

    <script type='text/javascript' src='http://mydomain/wp-content/plugins/infinite-scroll/infinitescroll.init.js.php?p=YToyOntpOjA7YTozOntpOjA7czoyNToiaHR0cDovL2JhYmVzb21nLmNvbS9wYWdlLyI7aT53dq51fI6IjkxMTM2NWE2MjdjNjMwNTU3NjQzMmY4ODJjYmI4Mjg4Ijt9'></script>

    Code that is being generated now and the html minication somehow breaks the script from working.

    I will work around it, i like this version better that doesn't display the path in the source.

    And to answer everyones questions yes my robots modification above in my previous post worked to solve this issue, i wish i had seen it earlier, my page dropped rank but its getting up there again.

  5. jeriksson
    Member
    Posted 2 years ago #

    Recently just upgraded to latest version 2.3.1 of wordpress and the release you gave me is broken for that version, for some reason it works perfectly for admin, but users won't get the scrolling effect. I'm setting it to "ON" which means on for all, but something tells me all the switches are broken, cause when i set the plugin to OFF it still scrolls for admin.

    Just a FYI, downgraded to the latest working build.

    Any updates coming, i really want to get rid of that pathparse in my html source code.

  6. jeriksson
    Member
    Posted 2 years ago #

    Just solved it, had to reroll the old version, enable that one, then just switch the files out, and now it's working with your build.

    Not very stable but working now again :) Thank you, pathparse is gone once more!

  7. beaver6813
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the delay in response! I've been really busy with work & other projects I'm afraid!

    Ahh that wp-minify thing is exactly the same problem another user was having (but we couldn't figure out what was causing it). Basically it tries to be clever and "word-wrap" my source code....

    // Define loading.msg
    opts.loading.msg = $('<div
    id="infscr-loading"><img
    alt="Loading..." src="' + opts.loading.img + '" /><div>' + opts.loading.msgText + '</div></div>');

    It does a lot of other nasty stuff that can break things but I'll try and come up with a work around. (This is the main reason why I haven't released build 220811 yet. 220811 also uses a different method for storing settings which is probably the issue you were having with "ON" not sticking. Just so I can try and recreate, did you originally have a WordPress site with released plugin or version 220811?

  8. jeriksson
    Member
    Posted 2 years ago #

    I'm unsure which version i had previous to yours, i think it was an earlier release then the current stable version.

    The way i fixed it was simply to download the latest release, swap out the plugin files, go into the settings, put it to "ON" then simply swap out the files.

    I've noticed other bugs with your latest release, example the "center" alignment for the image doesn't work, neither does right or left, it's always centered left for me, but that might be my theme's css that overwrites this setting as i haven't tested it with any other themes.

    Another thing to add would also be the ability to "not use an image", i currently replaced the default image with a white pixel 1x1 square just to get rid of it, not a very nice way of doing things ;)

    Anyways i do like the plugin, the infinte scroll is perfect for my site.

    Keep working on it, i love it!

  9. beaver6813
    Member
    Plugin Author

    Posted 2 years ago #

    The no image thing is a good idea, pretty easy to do as well. I'll look into putting it into the next main release when I get time!
    Yeah the alignment thing is pretty tricky as its easily overwritten by CSS. I'm not sure if theres any efficient way to do it.. maybe by attaching some CSS at the end of the page that'll overwrite any previous CSS.. its difficult!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic