WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Image Upload HTTP Error Fix] Plugin not working for me (17 posts)

  1. egographe
    Member
    Posted 6 years ago #

    Alas, This does not solve my problem: uploading a simple GIF image (200Kb) still causes the same HTTP error after the plugin has been activated...

    WordPress is getting Soooooo annoying with these king of javascript/ajax related issues that I'm seriously thinking of switching to another bloging engine! Too much is enought!

    http://wordpress.org/extend/plugins/image-upload-http-error-fix/

  2. RoseCitySister
    Member
    Posted 6 years ago #

    It worked for me at first, but now it "uploads" very quickly and cuts off the image, I only get a partial. Bummer! :(

    I won't be switching from WordPress though, it's not a deal breaker for me as there is a plugin that disables the flash upload.

  3. RoseCitySister
    Member
    Posted 6 years ago #

    Actually, I take that back - it's not working on one site that I've been using as a theme development sandbox. It works on my other installations.

  4. John Blackbourn
    Member
    Posted 6 years ago #

    @egographe, @RoseCitySister:

    Try this - after activating the plugin, go to the Settings menu in WordPress then click on the Permalinks submenu. Without changing anything, click the Save button at the bottom.

    If you get a message saying "You must now update your .htaccess file" (or something to that effect) then it means your .htaccess file isn't writable and therefore this plugin needs an extra step to work.

    Copy and paste the code you get given into your .htaccess file in the root of your WordPress installation (or create one if it's not already there). If you don't know what this means there are plenty of tutorials on the web about .htaccess.

    Once you've done this and saved your .htaccess file, try uploading again.

    If it works, great. If it doesn't, then you have a problem which I've not come across before.

    Hope this helps!

  5. RoseCitySister
    Member
    Posted 6 years ago #

    Thanks, I'll give that a try, although I think, because it's working on my other sites, that I've done something to the files to muck it up. Or it could just be a cranky spot on the server, who knows? lol

  6. John Blackbourn
    Member
    Posted 6 years ago #

    Version 1.1 released. Get it here.

    This should fix the bugs mentioned above (fingers crossed).

  7. casperse
    Member
    Posted 6 years ago #

    Its still not working...

    That is very very small picture files dont give any errors but a 300KB file will give the Http error?

  8. solecist
    Member
    Posted 6 years ago #

    I've got the problem, and re-applied my .htaccess
    ...still no upload...
    The new upload UI sucks....and in this case makes wordpress unusable!

  9. solecist
    Member
    Posted 6 years ago #

    Any other self-fixing options? server setup or anything?

  10. greatabeer
    Member
    Posted 6 years ago #

    DO not try this Plugin if you are not sure about the problem you are having in wordrpress 2.5.x as i have done so resulting in my web page giving error 500 and i was unable to open my website even with wp-admin.
    I found the .htaccess file in root menu that was hidden and we need to view hidden file to access it. I have deleted the lines this plugin added and FINALLY I can now open my site.

  11. wireless
    Member
    Posted 6 years ago #

    Rather than running the plugin what are the lines of code needed for htaccess ?

    Some of us can access .htaccess manually and would rather not run any more plugs Ta
    ;-)Graham

  12. John Blackbourn
    Member
    Posted 6 years ago #

    If you wish to add the .htaccess code in yourself, here it is:

    #BEGIN Image Upload HTTP Error Fix
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    <IfModule security_module>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    <IfModule security2_module>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    #END Image Upload HTTP Error Fix
  13. pishmishy
    Member
    Posted 6 years ago #

    This plugin is useful if you're not able to change the mod_security configuration using a .htaccess file or otherwise. It disables the flash uploader, reverting to the older style HTML based one.

    http://wordpress.org/extend/plugins/no-flash-uploader/

  14. Anonymous
    Unregistered
    Posted 6 years ago #

    I'm having the same problem (which I originally posted to http://wordpress.org/support/topic/179764?replies=7#post-802361). Installed John's plugin, but only after sorting out the htaccess.php write issue.

    The media uploader is still not working correctly. When I try to upload the file, I get "http error" and a frozen "crunching" on the file transfer status bar. The "Dismiss" button appears above the word "crunching" to the far right of the bar.

    Would love some help with thia!

  15. Anonymous
    Unregistered
    Posted 6 years ago #

    Thanks... pishmishy that plugin seems to have done the trick! Now lets see how it all goes with the new version of WordPress.

    Marcus

  16. dorischua
    Member
    Posted 6 years ago #

    I tried installing the plug in and it only works once and after that, the HTTP error persists. Anyone facing this problem again?

  17. tieguy
    Member
    Posted 6 years ago #

    johnbillion: for what it is worth, that htaccess fragment doesn't seem to be helping my problem. Same 'http error' and infinite crunching (with wp 2.6; firefox 3 + flash 9.0 on the client side.)

    After further investigation, it doesn't solve the problem probably because I don't have mod_security installed. :) So maybe I wouldn't advertise your fix as a generic http error fix; it seems to solve only one potential cause of the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic