WordPress.org

Ready to get started?Download WordPress

Forums

Image Rotator Widget
[resolved] Add image not working (6 posts)

  1. Naoise Golden Santos
    Member
    Posted 2 years ago #

    The plugin seems good, but when trying to add an image, the media window freezes and nothing happens.

    When clicking "Add to post" a JS error occurs saying that

    >iframjq is not a funcion:
    > if(iframejq("#src").length > 0) {

    I haven't found any reference in Google about iframjq, the most close is some TROJAN with iframe.jq in its name... may be a trojan got in my WordPress (although I am using the latest version) or the widget is malware (which I doubt).

    If someone had a similar experience I would like feedback on how to fix it or an alternative plugin for rotating images.

    http://wordpress.org/extend/plugins/dk-new-medias-image-rotator-widget/

  2. Naoise Golden Santos
    Member
    Posted 2 years ago #

    Ok, it is nothing related to a trojan. The plugin accesses the thickbox's iframe by iframe[0].contentWindow.jQuery; giving a function. This function is stored in the variable iframjq.

    When you click "Insert into post" this variable is undefined.

  3. Naoise Golden Santos
    Member
    Posted 2 years ago #

    I found a hack. The problem was mainly because the plugin is not localized, and the jQuery was referencing a button[value="Insert in post"], but my button's value was in Spanish.

    To fix it I changed line 146 of the plugin's main.js to:

    iframejq('.open .savesend input[type=submit]').each(function(i, e){

    It inserts more than one image but is good for now. I hope this helps until they can update the plugin. It is a really good plugin.

  4. srcoley
    Member
    Plugin Author

    Posted 2 years ago #

    This was a good catch. Thanks for being so vigilant a sniffing out the bug. I'll be updating the plugin early this month to include this fix and various others.

  5. sharonmiranda
    Member
    Posted 2 years ago #

    I have the same issue, window freezes. If, however, I select only one single image from computer, it will accept that. Not one from the media library. However, it accepts and then repeats it many times in the widget. I did make the code change as per Naoise Golden Santos. Any ideas or recommendations? And when the fix?

  6. NienkeC
    Member
    Posted 1 year ago #

    I have the same issue, window freezing after pressing "Send to image rotator". Doesn't matter if I do one or more images and if I upload or choose the media library.

    I hope there will be a fix, because this is the only plugin that does exactly what I need.

    Using wordpress 3.3.2 with the latest qtranslate.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic