WordPress.org

Ready to get started?Download WordPress

Forums

  1. epatience
    Member
    Posted 1 year ago #

    I've recently installed your plug-in and am having problems using it.

    The installation went smoothly. However when I tried to add an image to either a post or a page, the upload completes but then returns a message to me, "can't get response after file upload". No thumbnail becomes visible in the thumbnail area of your product in my post. The directory that I assume would contain the photos that I've uploaded are empty (.../uploads/2012/09)

    Cache directory authorizations are set to 755.
    Uploads directory authorizations are set to 755.

    I'm running on Windows 7 (64 bit) with Google Chrome (21.0.1180.89) on WordPress 3.4.2 with version 0.18 of image Pro

    http://wordpress.org/extend/plugins/image-pro-wordpress-image-media-management-and-resizing-done-right/

  2. mihaivalentin
    Member
    Plugin Author

    Posted 1 year ago #

    Hi epatience,

    I've had this issue with some other users as well.

    It seems that on some server configurations, the file that actually performs the upload is inaccessible due to some rewrite rules.

    Could you please open Chrome Developer Tools (press F12), go to the network tab, and then try and upload an image, and see if upload.php gives any kind of network error?

    Thanks,
    Mihai.

  3. nortont
    Member
    Posted 1 year ago #

    I seem to be having the same problem and looking at the F12, I see no errors.
    My install is a WP 3.4.2 running multisite

    Response

    {"ok":true,"data":{"file":"\/xxxx\/xxxx\/public_html\/wp-content\/blogs.dir\/1\/files\/2012\/11\/Coffee.gif","url":"http:\/\/xxxx.com.au\/charlottes\/files\/2012\/11\/Coffee.gif","attach_id":2842},"more":null}

    Headers

    Request URL:http://xxx.com.au/charlottes/wp-content/plugins/image-pro-wordpress-image-media-management-and-resizing-done-right/src/request/upload.php?name=Coffee.gif
    Request Method:POST
    Status Code:200 OK
    Request Headersview source
    Accept:*/*
    Accept-Charset:ISO-8859-1,utf-8;q=0.7,*;q=0.3
    Accept-Encoding:gzip,deflate,sdch
    Accept-Language:en-GB,en-US;q=0.8,en;q=0.6
    Connection:keep-alive
    Content-Length:61455
    Cookie:wordpress_4fb2d9f9500f00d498e28a5eaea8a96b=xxxx%7C1353410994%7C8424f7529f68ae3478bf4e843c04d214; wordpress_4fb2d9f9500f00d498e28a5eaea8a96b=xxxx%7C1353410994%7C8424f7529f68ae3478bf4e843c04d214; wordpress_logged_in_4fb2d9f9500f00d498e28a5eaea8a96b=xxxx%7C1353410994%7C61296f16e8fcdfdf4fd7a226ddd80957; __utma=40694206.72867421.1352027432.1352530169.1352722525.11; __utmz=40694206.1352027432.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); PHPSESSID=ffc7dbebddf0f139ddef42036f5d5ec5; wp-settings-1=editor%3Dtinymce%26align%3Dright%26imgsize%3Dmedium%26hidetb%3D1%26mfold%3Do%26wplink%3D1%26galcols%3D2%26cats%3Dpop%26woosidebarsshowadvanced%3D1; wp-settings-time-1=1352806210
    Host:xxxx.com.au
    Origin:http://xxxx.com.au
    Referer:http://xxxx.com.au/charlottes/wp-admin/post.php?post=300&action=edit
    User-Agent:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11
    Query String Parametersview URL encoded
    name:Coffee.gif
    Response Headersview source
    Cache-Control:no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Connection:Keep-Alive
    Content-Encoding:gzip
    Content-Type:text/html
    Date:Tue, 13 Nov 2012 11:32:47 GMT
    Expires:Thu, 19 Nov 1981 08:52:00 GMT
    Keep-Alive:timeout=2, max=95
    Pragma:no-cache
    Server:Apache
    Set-Cookie:woocommerce_items_in_cart=0; expires=Tue, 13-Nov-2012 10:32:49 GMT; path=/
    Transfer-Encoding:chunked
    Vary:Accept-Encoding
    X-Powered-By:PHP/5.3.13

  4. maedhros
    Member
    Posted 1 year ago #

    I have the same problem, in my server logs I have:

    [Sat Dec 08 16:06:16 2012] [error] [client 188.40.97.131] SoftException in Application.cpp:573: Directory "/path/to/vhost/html/wp/wp-content/plugins" is writeable by others, referer: http://<myhost>/wp-admin/post-new.php
    [Sat Dec 08 16:06:16 2012] [error] [client 188.40.97.131] Premature end of script headers: upload.php, referer: http://<myhost>/wp-admin/post-new.php

    Can you change the path for thumbnail cache to somewhere outside the plugins directory?

  5. mihaivalentin
    Member
    Plugin Author

    Posted 1 year ago #

    Hi maedhros,

    When you receive such an error from your server, it means that your files are writable by group and others. Your files should only be writable by your user.

    To solve this, go to that folder from FTP and remove the write permissions from "Group" and "Others" from that folder (plugins).

    Please try this and let me know if this works.

    Mihai.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags