WordPress.org

Ready to get started?Download WordPress

Forums

IM8 Box Hide
Auto-hides custom fields (10 posts)

  1. Naz
    Member
    Posted 3 years ago #

    I love this plug-in and it's exactly what I've been looking for, but I have one problem: I have several plugins (including Revisionary and Edit Flow) that add custom fields. The fields do show up in the IM8 Box Hide plug-in, but when I try to select or deselect them, other fields are automatically selected or deselected as well. It's like they are linked to each other and I can't enable/disable those boxes without enabling/disabling others.

    If this can be fixed, this plug-in will be even more awesome. :-) Thank you!

  2. intermedi8
    Member
    Plugin Author

    Posted 3 years ago #

    Hmmm, thats new =)

    Can you tell me exactly how i can reconstruct this behavior? I guess its because custom fields are different from metaboxes, they have have other IDs. But i will try to fix it and find a workaround ...

  3. Naz
    Member
    Posted 3 years ago #

    The custom fields are added to the IM8 Box Hide page, but when I select or deselect the checkboxes (I'm not sure, but it might have something to do with the select all buttons?) other fields (the WordPress ones, not custom fields )are automatically selected or deselected as well. It usually doesn't seem to show you the other checkboxes have been (de)selected until you reload the page.

    Here's a pic:

  4. Naz
    Member
    Posted 3 years ago #

  5. Naz
    Member
    Posted 3 years ago #

    Are there any updates on this? Thanks!

  6. 1Dog
    Member
    Posted 3 years ago #

    I'm experiencing the same problem. So bump!

    Any solutions?

  7. intermedi8
    Member
    Plugin Author

    Posted 3 years ago #

    Hello,

    please let me know which versions of wordpress you use and which plugins. I will set up a testcase to reproduce the problem and fix it.

  8. 1Dog
    Member
    Posted 3 years ago #

    Hi,

    Appreciate the help. My specs are:

    1. Latest version of WordPress
    2. Themes: Changing themes makes no difference.
    3. Plugins:
    - IM8 Box Hide
    - FieldPig
    - Custom Permalinks
    - Editor Tab
    - More Fields
    - IM8 Box Hide
    - Maintenance Mode
    - Restrict Categories
    - User Switching
    - WP-DBManager
    - TinyMCE Templates

    I've disabled all plugins except IM8 Box Hide, same result. I've uninstalled IM8 Box Hide and reinstalled - same problem remains.

    I've deleted old plugin tables from the database - same problem remains.

    I'll put screen shots at http://www.linkm9.com/screen1.html and screen2.html

    Thank you for helping.

  9. intermedi8
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm sorry, i cant reproduce the problem. I used the same configuration and get no problems. Even very "strange" configurations with multiple custom box plugins activated at the same time didnt get me in troubles. I guess it must be some kind of incompatibility with another plugin.

    Can u try to check it again on another fresh WP installation? Maybe its also a PHP or server problem?

  10. 1Dog
    Member
    Posted 2 years ago #

    I suspect this goes deeper than the plugins. So will look at a fresh WP instal and maybe, another host. Will post findings here, when I get to it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic