WordPress.org

Ready to get started?Download WordPress

Forums

IceCaptcha
"You do not have sufficient permissions to access this page." (7 posts)

  1. eracc
    Member
    Posted 1 year ago #

    I installed this under my Administrator user and am able to access the "wp-admin/options-general.php?page=icecaptcha/ice-captcha.php" page. I only want this for comments and tried deselecting the "Registration form" and "Login form" options. I also want the circle to be bigger and tried changing that to 20. Every time I click [Update Options >>] I get the message:

    You do not have sufficient permissions to access this page.
    -----
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, cgiadmin@... and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    I only have one Administrator account. How else am I supposed to set this up? Thank you.

    Added: For the moment I am having to leave this disabled because the circle is so small on the login page on my monitor it is almost impossible to see.

    http://wordpress.org/extend/plugins/icecaptcha/

  2. eracc
    Member
    Posted 1 year ago #

    More information. If I try to access the "wp-admin/options-general.php?page=ice-captcha/ice-captcha.php" from Settings on the "wp-admin/plugins.php" page, I get the same error as above. If I use the side-bar menu under Settings > Ice Captcha, I am able to get to the settings page. But I still cannot change the settings from the default and receive the error above when I try.

    A little help would be appreciated here. Thanks.

  3. eracc
    Member
    Posted 1 year ago #

    Yet more information. Every other plugin or action I try as my administrator user works without error. It is only this plugin that is causing me grief. I have it enabled for now and am going to try to use it "as is" even though I cannot change the settings. But I will not keep using a plugin over which I cannot control the settings. It would really be nice to hear back from the author of this plugin. Thank you.

  4. swisssnowman
    Member
    Posted 1 year ago #

    Same here!!
    Just installed and get the same error.
    I know it's a free plugin, but still... would be good to have some answer.
    Thanks

  5. HH2200
    Member
    Posted 1 year ago #

    Access IceCaptcha via the left side panel: Plugins. Then choose Editor. Then choose Select plugin to edit (in the righthand upper corner). Then press Select. You can edit your files here. Works for me.

  6. eracc
    Member
    Posted 1 year ago #

    Yes, I can edit the files and already know how to do that after several years of working with WordPress. I can even edit them offline and upload new copies if needed. That is not the problem. The problem is an incorrect check for permissions as far as I can see. I would like to have that fixed so that I can recommend this plugin to clients.

    I install and configure CMS sites for clients, but I am not a PHP guru by any means. So, this error stops me from being able to use IceCaptcha for my clients who are most definitely not comfortable with editing the source files. If I knew where and what to edit to change the permission checks and stop this error message, I would do that and use a modified IceCaptcha for clients.

  7. IceCaptcha
    Member
    Plugin Author

    Posted 1 year ago #

    We have fixed this bug in new version - 2.1. New release ready to download right now. Thank you for your bug report!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic