WordPress.org

Ready to get started?Download WordPress

Forums

Hyper Cache
How do you get it to start caching? (8 posts)

  1. Summerock
    Member
    Posted 3 years ago #

    I have installed -> enabled, but it is not doing anything. Am I missing a step?

    http://wordpress.org/extend/plugins/hyper-cache/

  2. jtimar
    Member
    Posted 3 years ago #

    Ditto here. I gave up.

  3. jtimar
    Member
    Posted 3 years ago #

    BTW, I noticed there is a rather rude response in a closed thread with the same question, from Pinoy.ca.

    There is nothing to elaborate on. On my setup, which is a fairly standard installation, hypercache does nothing. Evidently Summerock has the same issue.

    Nothing to elaborate on.

  4. tohal
    Member
    Posted 3 years ago #

    Same here. I’ve installed hyper cache both on my blog at my host and on a local xampp site on my PC and I just can’t get any pages to appear in the cache in either setup.

    Details (for the “real” blog) are as follows:
    Softaculous installation of WP 3.0.4
    The following items are set or ticked / checked in the settings (where in doubt, I’ve left the defaults):

    Cached pages timeout – 1440 minutes
    Cache invalidation mode: Only modified posts
    Invalidate home, archoves, categories on single post invalidation
    Disable cache for commenters
    Enable compression
    Redirect caching
    Page not found caching (HTTP 404)

    Shame – the reviews for Hyper Cache rave about it.
    Anyone got any ideas what could be happening?

    Thanks

  5. Gestroud
    Member
    Posted 3 years ago #

    Having "Disable cache for commenters" unchecked and "Disk space usage" along with "Disable Last-Modified header" checked seems to work well on my server. All my other settings are the same as yours.

  6. angophora
    Member
    Posted 3 years ago #

    It only caches pages when they are loaded by users that are not logged in. So I'm wondering if that's the issue here? If you are logged in it won't cache.

    I found that the default settings worked fine - I did a Network Install in a multisite network and initial indications are that it's working.

  7. archiseek
    Member
    Posted 3 years ago #

    Wasnt working for me and then I saw elsewhere...

    create a subdir called cache in the hypercache dir
    chmod 777 and away it goes

  8. happyches
    Member
    Posted 3 years ago #

    Did you also add

    define("WP_CACHE", true);

    To the wp-config.php file beneath:

    define('WPLANG', '');

    I did that and chmod 777 to the cache folder and mine is working great and I have wordpress 3.1 which is supposedly not supported yet by the plugin.

    I also made sure to visit each page not logged in as per the comments above to force each page to create a cached copy.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic