WordPress.org

Ready to get started?Download WordPress

Forums

Hyper Cache
Cleaning process:Next run on: January 1, 1970 02:00????? (12 posts)

  1. phattrance
    Member
    Posted 3 years ago #

    Does anyone know why the Cleaning process is set automatically to 1 jan 1970? the server time settings etc are correct so i dont know why hyper cache cleaning process is set to the year 1970!

    any ideas?

    Screenshot: http://egetfoto.se/?v=screen-1301412015.jpg

  2. phattrance
    Member
    Posted 3 years ago #

    anyone?

  3. kokopelli
    Member
    Posted 3 years ago #

    I'm seeing a similar problem on some of my sites, except the date is stuck on "December 31, 1969". The result is that the cache doesn't get cleaned and I sometimes run out of server space, which necessitates a manual clean.

    The solution, for some of these sites, has been to deactivate and reactivate the Hyper Cache plugin. But that doesn't always work.

    Any ideas/suggestions?

    Thanks for a great plugin - I use it on all my WordPress sites!

  4. phattrance
    Member
    Posted 3 years ago #

    yeah i tried to deactivate and activate the plugin, it did change the date, but still the wrong date, so i downgraded the plugin to a older version!

  5. kokopelli
    Member
    Posted 3 years ago #

    Try this (it just worked for one of my sites) - check and see via cPanel/phpMyAdmin if your wp_option table isn't corrupt/has a problem.

    If so, do a repair - it fixed the date issue on one site (so far)!

  6. phattrance
    Member
    Posted 3 years ago #

    didnt work, any other ideas?

  7. kokopelli
    Member
    Posted 3 years ago #

    Dunno ... maybe check that your timezone settings in the backend (Settings > General) are correct and correspond with your server time. There are known issues where they don't.

    Then, maybe deactivate/reactivate the plugin again?

    Apart from that, I'm afraid, I can offer no further advice - hopefully, the plugin author can.

  8. Stefano Lissa
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, I'll check if in latest version I changed something about the cleaning process (even if I'm pretty sure I didn't anything on it). When you see 1970 or lower, it means there is no cleaning scheduled.
    Deactivating and reactivating the plugin should restart the hyper cache cleaning event, but if it still is reported as 1970, it has not been registered.

    Timezone influence only how the date is written, adding or subtracting time time zone difference in hours (so some of you see 1969).

    I'll report you ASAP.

  9. Stefano Lissa
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, some of you can istall the http://wordpress.org/extend/plugins/wp-crontrol/? It creates two control panel: one under setting and one under tools.
    The one under setting should report the schedules type on wordpress and the one under tools the next event to be launched.
    Copy the tables here or report to me on stefano@satollo.net.

  10. phattrance
    Member
    Posted 3 years ago #

    u got mail!

  11. Stefano Lissa
    Member
    Plugin Author

    Posted 3 years ago #

    I've just committed the version 2.8.0 with a stupid change that, as far as I know, does not solve the problem... but if you want to upgrade (it's identical to version 2.7.9, only on activation it remove the hyper schedule and add the new one).

  12. Stefano Lissa
    Member
    Plugin Author

    Posted 3 years ago #

    Just a note: the cleaning process starts every hour, not based on cache life time. If you need I can give a technical explanation.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic