WordPress.org

Ready to get started?Download WordPress

Forums

Hyper Cache
Cache files never created (12 posts)

  1. NickNiebling
    Member
    Posted 2 years ago #

    Thank you for doing a great job getting this plugin up and running.

    However, it seems like the bug with new version hasn’t been fixed yet – even though we are several versions further than this post (http://www.satollo.net/hyper-cache-2-6-6-and-wordpress-3-0).

    I’ve got the latest and greatest version of WP and Hyper Cache on my brand new WP blog.

    I did visit and browse the site with IE private browsing and Chrome Inkognito. No signature (browsed the same 10 pages a lot of times).

    So the Cleaning process seems to be working just fine (updating the “next clean stamp”).

    I’ve changed the chmod of the cache (and hyper cache subdir) to 777. I only get 1 file in my cache folder: “_archives.dat”. The file is empty and I don’t know when the file is generated, but it seems to change the file last modified date on a regular basis.

    I’ve tried to deactive the plugin and reactivate. Tried to deactive, delete, install and activate. Tried to deactive, delete manually, manually delete cache folder, install and activate. All with standard settings.

    I did try to disable the “Disk space usage” setting at first use – but it seemed to be buggy to just save that setting (it kept checked/active).

    WordPress version: 3.2.1
    Hyper Cache: 2.8.5

    I’ve got a custom theme – so maybe I need to include some WP-stuff I don’t know about? Do you require more than wp header and wp footer?

    I’ve been using other cache plugins before, but I read a good benchmark of your plugin putting Hyper Cache in front of all the others competitors, so I would really like to try it out and maybe use it for all my blogs in the future. (Donations are of course given to my favorite plugins)

    Mvh.
    Nick Niebling

    http://wordpress.org/extend/plugins/hyper-cache/

  2. maxoud
    Member
    Posted 2 years ago #

    I've faced the same problem today and I've got a superficial solution:

    • open cache.php inside hyper-cache folder;
    • find the line containing if (!file_exists($hc_file));
    • remove return; after that line and before following curly bracket.

    Ugly bug...

  3. NickNiebling
    Member
    Posted 2 years ago #

    Thank's for the feedback. I found this in plugins/hyper-cache/cache.php:

    if (!file_exists($hc_file)) {
        hyper_cache_start(false);
        return;
    }

    But it didn't help to remove the return. Could you please verify you got the same code in your file and you edited it to:

    if (!file_exists($hc_file)) {
        hyper_cache_start(false);
    }

    I've been looking for a solution for a long time now :-( And it's so frustrating..

  4. maxoud
    Member
    Posted 2 years ago #

    Hello, Nick!

    Don't follow my instructions!. I've dug deeply into the plugin code and understood I'm wrong. Sorry for that.

    See what happens when you logout and clean up cookies set by your WP installation. If nothing new - deactivate all plugins except Hyper Cache and see what happens then. Also you can try to switch to default template.

    In my case it was bad buffering stacking (nested ob_start) caused by custom theme.

  5. NickNiebling
    Member
    Posted 2 years ago #

    IE Private browsing and Chrome inkognito both cleanup all cookies etc. and make a "fresh browse" - but still no cache..

    I'll try disable my plugins and change theme to see what happens with the caching.

    I'll post any update on this matter here later today..

  6. NickNiebling
    Member
    Posted 2 years ago #

    Disabling all plugins makes no difference.
    Using default theme "solves" the issue.. So it must be theme related..

    It would be nice to know how the plugin rely on theme structure.. I'm still doing a lot of debugging trying to find out whats wrong..

  7. NickNiebling
    Member
    Posted 2 years ago #

    Before (trying) to use a caching plugin, the theme had tried to do some speed optimization itself by using zlip to gzip the output for minimized bandwidth transfer..

    Well.. It's clear to me - DON'T :-)

    Here is the code I've removed from my functions.php:

    if(extension_loaded("zlib") && (ini_get("output_handler") != "ob_gzhandler")) {
    	add_action('wp', create_function('', '@ob_end_clean();@ini_set("zlib.output_compression", 1);'));
    }

    Author: http://stffn.dk/2011/04/useful-wordpress-functions/

    (The script works just fine - just not together with caching)

  8. maxoud
    Member
    Posted 2 years ago #

    Nick, can you send me zipped theme you use, please. maxyudin[]gmail.com

  9. NickNiebling
    Member
    Posted 2 years ago #

    Well no.. It's a custom theme..

    My Advice is to try following:

    1. Disable all plugins but Hyper Cache (if it works, enable one at a time to find the blocker)
    2. Change to standard theme - if it works, go back to your theme and try:

      1. Disable all in your functions.php
      2. Disable all not standard WP in header.php
      3. Disable all not standard WP in index.php
      4. Disable all not standard WP in footer.php
  10. Daedalon
    Member
    Posted 2 years ago #

    Had a similar problem in multiple blogs due to different causes. The problem was that Hyper Cache wasn't doing anything no <!-- hyper cache... tag in the source code, no cached files shown in admin panel. These three steps solved it:

    1. Chmod 777 wp-content/cache/hyper-cache (if it wasn't created, Hyper Cache 2.8.5 told to create and chmod 777 - if it was created with eg. 755, Hyper Cache didn't work but didn't give any notice either)

    2. Chmod 777 wp-content/advanced-cache.php. Before this when changing options, Hyper Cache said "Options saved BUT not active because Hyper Cache was not able to update the file wp-content/advanced-cache.php (is it writable?)." It's rather confusing that options can be saved so they look like they're set one way, but they are not active so the real active settings are still the old way. This I find to be rather wrong and I hope Hyper Cache wouldn't save options that aren't also actively used.

    3. After the chmods save the Hyper Cache options in admin panel. No options needed changing, just saving. See above #2 - maybe the active settings were something else than the admin panel showed until chmod + resaving settings forced the visible and active settings to be the same.

    How to improve Hyper Cache:

    4. Make Hyper Cache both to create the necessary directories and files and to chmod them correctly

    5. If that's not possible, make sure Hyper Cache tells what exactly needs to be done. Eg. "directory wp-content/cache/hyper-cache exists but needs to be set chmod 777" instead of saying nothing and "wp-content/advanced-cache.php needs to be set chmod 777" instead of asking "is it writable?".

    6. In Hyper Cache admin panel, always show the active settings. Don't allow saving options that will not be active.

    Thanks for the work with the plugin and hopefully this feedback will help improve it even further!

  11. Patrick Nommensen
    Member
    Posted 2 years ago #

    @Daedalon. I'm also having this issue. The hyper-cache folder wasn't created so I went ahead and created it. The advanced-cache.php was also not created. Where can I find/download this file? I'm having a tough time being able to cache on our new site - any help would be really appreciated!

    EDIT: I chmod 777 and reinstalled the plugin - now all the files and folders were created. However, it doesn't seem to cache any files in the cache/hyper-cache folder.

  12. Daedalon
    Member
    Posted 2 years ago #

    Hope you got it up and running well, Patrick.

    Having used Hyper Cache for more than a year now, I have yet to put it into a proper stress test. The last proper benchmark I've seen that included Hyper Cache was from 2010.

    WP Super Cache was featured on http://kbeezie.com/view/caching-wordpress/ (2011) and http://cd34.com/blog/scalability/wordpress-cache-plugin-benchmarks/ (2010) with excellent results.

    http://scratch99.com/wordpress/reviews/wordpress-caching-plugins-for-shared-hosting/ (2010) has some interesting points. Namely that the results of a caching plugin are different for each server setup and plugin combination. In the benchmark they used, Hyper Cache fared better than Super Cache.

    http://blog.ryantoohil.com/2012/03/a-quick-bit-about-wordpress-caching.php (2012) is the newest one and benchmarks only two plugins. Hyper Cache shows a clear improvement, but W3 Total Cache is a lot better. No mention of the configuration used.

    And last, http://h-dee.net/optimize-wordpress-website-with-caching-plugins/ (2011) recommends "Hyper Cache, DB Cache Reloaded, and WP Minify combination."

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic