WordPress.org

Ready to get started?Download WordPress

Forums

Hikari Email & URL Obfuscator
[closed] unable to install on wp3.1alpha (7 posts)

  1. C0BALT
    Member
    Posted 3 years ago #

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Class 'HkMuob_Op' not found in /home/XYZ/public_html/wp-content/plugins/hikari-email-url-obfuscator/hikariobfuscator-options.php on line 6

  2. C0BALT
    Member
    Posted 3 years ago #

    I still receive the same error with 3.1beta1

  3. shidouhikari
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry, I'm still using 3.0.1. It's great to follow beta versions to keep track of new features, but some of my plugins don't even use 3.0 features yet. Also, it's already hard to support 2.8, I can't really test beta versions.

    I only start supporting new versions when they get stable (what generally happens when 2nd subversion is released, like 2.9.2 and 3.0.2). I only started 3.0 branch earlier because of MultiSite features and a new filter I needed in a plugin and was added in 3.0.

    When new version is released, it uses a much better way of loading the plugin and instatiating its objects.

    But based on this error message, it looks more like a PHP error. Of course the class is there, or maybe the file is corrupted. Just give me some time and I'll move to 3.1... .2 :)

  4. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    shidouhikari -

    77% of installs (and that's not even active installs) are running 2.9 or higher. I would change your support from 2.8 to at least 2.9+.

    There's no way to predict that X.0.2 will ever be release. Both 2.9.2 and 3.0.2 were security-related releases. Otherwise we only would have had 2.9.1 and 3.0.1.

    It reflects poorly on WordPress itself when their sites break after updating, even if it's due to a plugin. Some effort during the beta period goes a long way :-)

    Nacin

  5. shidouhikari
    Member
    Plugin Author

    Posted 3 years ago #

    Yeah I know, but now we're on 3.0.4! In the last milestones it always happened.

    Don't take me wrong, core contributors do a great job making x.x.0 stable, but sometimes there's some bug that's not detected and only fixed on x.x.1, and there may be security fixes that bring uns x.x.2 and even more.

    I wanted to test it during beta, I wanted to HELP develop and debug WP. But I barely am able to support my plugins and maintain my sites. So I prefere to wait for final WP version when I don't have time to test it earlier.

  6. shidouhikari - That's a perfectly valid way of operating though I would strongly suggest you make that clear on your plugin FAQs and pages. "This plugin IS NOT supported on beta/dev versions of WordPress, and will not be supported on new releases immediately."

    People expect plugins to keep working on minor upgrades, and most of 'em expect it on major ones too. This is a part of being a plugin dev :)

  7. dsided
    Member
    Posted 2 years ago #

    Hi shidouhikari - any news on this please? Been 8 months now, many thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic