WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Hikari Email & URL Obfuscator] Obfuscate your emails and URLs! (3 posts)

  1. shidouhikari
    Member
    Posted 4 years ago #

    Hello, I've just published my obfuscation plugin, Hikari Email & URL Obfuscator.

    It filters posts, comments and text widgets to obfuscate all found links.

    Links are shown by JavaScript enabled and disabled browser ("no "activate JavaScript to see my email" messages! :D ).

    When JavaScript is available it randomly uses ROT13 or cc8b to encode links while PHP is building the page, and then JavaScript decodes them and updates the page with correct links.

    For JavaScript disabled browsers, it adds gibberish in the middle of the email/URL, and doing so spam and search bots can't understand what's there, but CSS makes these extra texts not to be rendered and browsers show original emails/URLs to real users.

    The plugin main page is http://Hikari.ws/email-url-obfuscator/ soon I'm gonna publish an article with advanced usage tutorial and another article with a lot of exemples and tests.

    I'd like to hear what people think of it and ideas to make CSS reversion work without breaking XHTML validation. :)

    http://wordpress.org/extend/plugins/hikari-email-url-obfuscator/

  2. Mr.Spots
    Member
    Posted 4 years ago #

    Hi,
    it seemed like a very good idea to use your obfuscation-plugin. Unfortunately, it went only as far as the first click on "activate":
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /ROOTDIRECTORY/wp-content/plugins/hikari-email-url-obfuscator/hikari-tools.php on line 18
    I'm running an out-of-the-box WP 2.9.2 with just one other plugin installed (Fixed Social buttons) but a PHP 4.x. Does your plugin perhaps require PHP 5 or above?
    However that might be, you should perhaps consider implementing some try-catches to tell the user, what went wrong and why.

    Mr.Spots

  3. shidouhikari
    Member
    Posted 4 years ago #

    yes, it requires PHP5

    IDK how to verify PHP version, I'll try to learn how that could be done and implement it.

    anyway, PHP4 is very old and I believe it's not supported anymore, OOP is a must-have, I suggest ppl to update it because PHP5 has better features :)

    Also, take a look at http://Hikari.ws/email-url-obfuscator/#comment-1741

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.