WordPress.org

Ready to get started?Download WordPress

Forums

Hide Widget Title
Can still see widget titles (14 posts)

  1. thatwastaxing
    Member
    Posted 3 years ago #

    Hi,

    I've just installed your plugin and set a couple of widget titles to be hidden from public view but I can still see them.

    I've cleared the cache and tried it on the latest versions of Chrome and FF.

    http://wordpress.org/extend/plugins/hide-widget-title/

  2. Adam W. Warner
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for reporting this. Just a couple days ago we've discovered that there is an issue depending on how your theme writes the widget title html AND what header tag it is using (h3, h4, h5) etc.

    The plugin currently only hides the h3 tag and I have a fix ready to submit to the plugin repository that will include the hiding of all header tag sizes...however, in testing, there is still the issue in how different themes write the html/css for the widgettitle and I'm hoping to include that in the update as well.

    If I don't get a solution for that within a few days, I'll submit the other update on it's own.

    Can you link to your site so I can check your header tag size?

  3. akoetsier
    Member
    Posted 3 years ago #

    Hi awarner20 , i was just about to email you but glad i google'd it first ;)
    I am having the same issue here , see MySite please.
    I am very glad you made this plugin , the titles take up important space and sometimes are completely unnecessary.

    I hope you can make this fix soon , great job!

    Alvin

  4. gilnamur
    Member
    Posted 3 years ago #

    Hi awarner20,

    Well done! FINALLY someone looks after a huge annoyance.
    Happy to beta test if you have need!

    Also, when its done, I will link to you here:
    http://lifeasahuman.com/life-as-a-human-site-enablers/

    Are you close to release?
    Cheers,
    Gil

  5. Adam W. Warner
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Gil,

    Hopefully I'm close...been battling illness and have gotten behind on more pressing projects. Will try for an update over the weekend.

  6. gilnamur
    Member
    Posted 3 years ago #

    Hope you feel better soon! I was sick for 4 weeks ... no fun.

    Remember if you need testers, I am available.
    Cheers,
    Gil

  7. joliesky
    Member
    Posted 3 years ago #

    Hi! I have two wordpress sites and I recently uploaded your plugin to both of them. It seems to be working on one site, but not the other. I installed the plugin on my sports site last night, and it worked at first, but when I came into work this morning, it's not working now. Do you have any suggestions?

    http://www.abqjournal.com/sports

  8. joliesky
    Member
    Posted 3 years ago #

    Also, I have already tried switching my widget title headlines to h3, and that still didn't work.

  9. Adam W. Warner
    Member
    Plugin Author

    Posted 3 years ago #

    Hi all,

    Good news and bad news.

    First, the bad news...there is no update for this plugin yet.

    Good news...it's still on the radar here.

  10. Web2Guru
    Member
    Posted 3 years ago #

    How it coming? Hope you feeling better. I'd like to see this working too, I have a use for it right now but it doesn't work because this theme uses h4 tags.

    For those who need it to work, and don't want to wait for the update, I figured out there is a very simple style sheet in the plugin folder that you can change each h3 to the tag your theme uses. That fixes the first bug, but if you have the other bug with how different themes write the html/css, I might look into it at some point, especially if I need to use a theme that triggers this problem.

    On a side note, another bug, it not only removes the title but it also removes any other headings from the widget content that match. The main reason I wanted to use the plugin was to hide the default title and put a different one in the content. Specifically, the headers are left-aligned by default, but I have one widget I wanted to center the title, so I used this plugin to remove the title and added the heading in the content inside a centered div.

    A suggestion, instead, add a class to the widgets first header, and hide that class. Might solve all the problems!

    For others with the heading in the content problem, it is a little messy, but I added a class .unhide with display set to inherit, and added the class to my headings in the content. Works for me!

  11. Web2Guru
    Member
    Posted 3 years ago #

    Regarding the hidden headings in the widget content:

    After looking some more, my theme's widget content is inside a nested div with the class textwidget, like so:

    <div id="text-6" class="widget-container widget_text">
    <h4>This is the title</h4>
    <div class="textwidget">
    <div style="text-align:center;">
    <h4>This is the heading in the content</h4>
    </div>
    ...

    I figure this might be standard, if it is you can fix this easier. Instead of making a unhide class and applying the class to my headings in the widget content, I used the class textwidget to reset the headings the same way.

    Example:

    BEFORE
    .unhide {display: inherit !important;}
    AFTER
    .textwidget h4 {display: inherit !important;}
    FOR ALL
    .textwidget h1,
    .textwidget h2,
    .textwidget h3,
    .textwidget h4,
    .textwidget h5,
    .textwidget h6
    {display: inherit !important;}
  12. Web2Guru
    Member
    Posted 3 years ago #

    By the way, I forgot to mention the !important part of the styles, not sure if the second method needs this, but the first method that adds the unhide class does need to have !important in the styles, like this:

    #text-9 h4 { display:none; }  #text-8 h4 { display:none; }  #text-6 h4 { display:none; }
    .unhide { display: inherit !important; }

    (That is the whole style sheet)

  13. Web2Guru
    Member
    Posted 3 years ago #

    Heheh, I should test more thoroughly before posting, lol. Editing that style sheet is pointless because it is recreated any time you change the hide setting on a widget. So instead add the code to your themes style sheet, usually in /wp-content/themes/your-theme/styles.css.

  14. Web2Guru
    Member
    Posted 3 years ago #

    And in the ajaxwidget.php, at line 10, change the h3 to the heading tag your theme uses, mine uses h4, which should look like this:
    $description = "#".$title." h4 { display:none; }";

    Then un-check, Save, re-check, and Save on all the widgets which should be hidden.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic