WordPress.org

Ready to get started?Download WordPress

Forums

Hide Login+
[Plugin: Hide Login] Not working on redirects (13 posts)

  1. douglaskastle
    Member
    Posted 2 years ago #

    When I downloaded and tried to use this plugin, none of the redirects worked, it does however still successfully disables access to wp-admin if enabled. I am using wordpress under a dreamhost install.

    http://wordpress.org/extend/plugins/hide-login/

  2. Okoth1
    Member
    Posted 2 years ago #

    Same here. This plugin doesn't work under 3.4.1

  3. dukejames27
    Member
    Posted 2 years ago #

    I'm having the same problem here. Login Redirect is not working.

  4. parswp
    Member
    Plugin Author

    Posted 2 years ago #

    this plugin works with all recent wordpress versions.
    u should just check if any other security plugins are installed!

  5. dukejames27
    Member
    Posted 2 years ago #

    I just installed wordpress brand new with the latest version of hide-login.

    I removed the default plugins (akismet and hello dolly). With Hide-Login installed, I added the login slug "logins". I can now access the login screen from '/wpadmin' and '/logins'.

    Then I chose "Hide Mode". Now neither slug works.

    To perform this test, I'm using IE to configure wordpress and firefox to test the login access. WordPress is installed on a Windows Vista system using xampp.

    I hope this information helps and thanks.

  6. dukejames27
    Member
    Posted 2 years ago #

    I've opened the .htaccess file to review what has been written. Please find the code below.

    # hide-LOGIN
    RewriteEngine On
    RewriteBase /
    RewriteRule ^logout wordpress/wp-login.php?action=logout&_wpnonce=5b7d1f20b4 [L]
    RewriteRule ^admin wordpress/wp-admin/ [R,L]
    RewriteRule ^logins wordpress/wp-login.php?&redirect_to=http://localhost/wordpress/wp-admin/ [R,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END hide-LOGIN

    # HIDE-LOGIN
    RewriteEngine On
    RewriteBase /
    RewriteRule ^logout wordpress/wp-login.php?action=logout&_wpnonce=5b7d1f20b4&hide_out_key=dmA0bv [L]
    RewriteRule ^logins wordpress/wp-login.php?hide_in_key=074rB&redirect_to=http://localhost/wordpress/wp-admin/ [R,L]
    RewriteRule ^admin wordpress/wp-admin/?hide_admin_key=0C3A0a0Aae [R,L]
    RewriteCond %{HTTP_REFERER} !^http://localhost/wordpress/wp-admin
    RewriteCond %{HTTP_REFERER} !^http://localhost/wordpress/wp-login\.php
    RewriteCond %{HTTP_REFERER} !^http://localhost/wordpress/logins
    RewriteCond %{HTTP_REFERER} !^http://localhost/wordpress/admin
    RewriteCond %{QUERY_STRING} !^hide_in_key=074rB
    RewriteCond %{QUERY_STRING} !^hide_out_key=dmA0bv
    RewriteCond %{QUERY_STRING} !^hide_reg_key=A0
    RewriteCond %{QUERY_STRING} !^hide_admin_key=0C3A0a0Aae
    RewriteRule ^wp-login\.php http://localhost/wordpress [L]
    RewriteCond %{QUERY_STRING} ^loggedout=true
    RewriteRule ^wp-login\.php http://localhost/wordpress [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END HIDE-LOGIN

  7. parswp
    Member
    Plugin Author

    Posted 2 years ago #

    new version of plugin released, please check it out and let me know the result.
    thanks

  8. douglaskastle
    Member
    Posted 2 years ago #

    OK that seems to have fixed part of my problem.

    Maybe I am confused on correct operation. With this corrected plugin when it is set to 'on' on the config page but hide mode is disabled the login slug you enter now correctly redirects to wp-admin.php.

    http://example.com/holodeck ->
    http://example.com/wp-admin.php

    However when the hide mode is enabled and you try and go to the page created by the login slug, you only get the front page, with this in the url bar:

    http://example.com/?&redirect_to=http://example.com/wp-admin/

    I thought, maybe inaccurately, that it would bring you to the login page.

    Is it possible to get to a login page if hide mode is enabled? If not how is one supposed to administer the site.

  9. dukejames27
    Member
    Posted 2 years ago #

    Thanks for the update parswp. Unfortunately, the update did not work. By uninstalling Hide-Login, removing the '.htaccess' file and starting over again, things seem to be working now. Perhaps if users having trouble disable Hide-Login, manually remove the code placed by this plugin and start over again, they too will have success? I outline what I've done below.

    At first, even with Hide-Login disabled, the custom slug I made still took me to the login page.

    Second, with Hide-Login enabled and Hide mode disabled, I tried changing the login slug. All three login slugs worked! This was a bit scary. Disabling and enabling Hide-Login didn't make a change. Nor did deactivating and reactivating it. Even after deleting the plugin, all three slugs worked.

    Only after removing the '.htaccess' file did my settings revert to defaults.

    After re-installing Hide-Login, everything seems to be working now. I believe that by removing the '.htaccess' file and starting over, everything was fixed. As if the plugin was able to apply the correct code. Removing the custom code in the file placed by 'Hide-Login' probably would've helped as well.

  10. dukejames27
    Member
    Posted 2 years ago #

    One thing though. When a person enters the incorrect login slug, what page are they supposed to see? Which file is supposed to load?

    As I mentioned, my testing environment is on a xampp server? By default, the root folder for the site has an 'index.php' file which appears to forward me to the 'splash.php' in the xampp directory.

    It doesn't seem to matter what incorrect address I use for the wordpress site, I'm automatically thrown to that splash page. Is this an affect of the '.htaccess' file changes?

  11. Okoth1
    Member
    Posted 2 years ago #

    Never spent so much time on a plugin to get it to work. It still doesn't work and I'll give up.

    Thanks for your efforts.

  12. Okoth1
    Member
    Posted 2 years ago #

    ... so I wrote my own simple version that worked perfectly with custom url, wp-admin and wp-login.php.

    Thanks for the inspiration!

  13. douglaskastle
    Member
    Posted 1 year ago #

    Yeah I got mine to work by deleteing the .htaccess and the plugin regenerated a new one.

    I did it with a clean install of wordpress, and it didn't work. The issue seems to be that the plugin is appending to the existing .htaccess and not rewriting. You can see it above where it repeats some commands, for example:

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    I am happy that i got it working, but for a new person downloading this plugin, it is still broken

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.