WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: HGK SMTP] Don't get the test mail (9 posts)

  1. maorb
    Member
    Posted 4 years ago #

    Hi,

    I've made the settings for Gmail and tried the test mail via the plugin, but I haven't received any test mail...
    What can it be?

    Thanks

    http://wordpress.org/extend/plugins/hgk-smtp/

  2. ihagaki
    Member
    Posted 4 years ago #

    1. Please make sure you have no other plugins with similar functionality active. If necessary deactivate them.
    2. Use exactly the following settings:
    SMTP server address: smtp.gmail.com
    Use SSL connection: checked
    SMTP server port: 465
    3. Fill in your specific account details:
    SMTP username: your_gmail_name@gmail.com
    SMTP password: you_gmail_password
    4. Clear "Sender e-mail" and "Sender Name" entries.
    5. Save the changes.

    6. Send a test e-mail.

    Please note that if you are sending to your own gmail account (the one in step #3 above), it won't appear in your inbox - check your sent folder instead. This is a standard gmail behavior.

    Can you drop a line back with the results?

    Thanks!

  3. maorb
    Member
    Posted 4 years ago #

    I've used exactly these settings, but none happened.
    The test result giving no line there.
    Just the heading test result and a button to go back to options.

    It's a bit problem to deactivate other plugin, I have a plugin which is subscribe to comments via mail, if I'll disable it users won't be able to subscribe to comments anymore.

    I've sent the mail to another mail, no to my Gmail account, but looked in the Gmail sent items, and there's no mail sent from there.

    Is there any other thing I might do ?
    Thanks

  4. ihagaki
    Member
    Posted 4 years ago #

    Well, we can try to dig a little deeper :)

    What version of WP do you use?
    What operating system it is run on?
    Do you use a web hosting provider?

    Can you also send a screenshot of your WordPress "Manage Plugins" page?
    Send it by email - here is the page with support email address: http://www.ihagaki.com/contact-us/

    Once I have those details, I'll see what I can do.

    Thanks!

  5. maorb
    Member
    Posted 4 years ago #

    I use WP2.84
    I use a host provider which runs hundreds of WP site, with regular LAMP.

    Well... My WordPress is in Hebrew, do you really want a screenshot ? :-)

  6. ihagaki
    Member
    Posted 4 years ago #

    Most probably you have a plugin that misbehaves. Some bring their own copy of phpmailer classes and / or override standard wordpress wp_mail() function.

    To diagnose, you can try temporarily deactivate some plugins just to see whether HGK SMTP will be able to send test emails without potential interference. Then activate them back.

    I understand that if you have high traffic site, that may be a bad idea, this is why I ask for the screenshot. Actually I just wanted a list of your plugins - (unless you have dozens :) I could install the same set on my test wordpress box to see what's going on.

  7. grantwp3
    Member
    Posted 4 years ago #

    I'm having exactly the same problem as maorb with a brand new installation of HGK SMTP and a recently upgraded version of WordPress (2.8.4).

    I am using all the default settings for gmail, and have tried two different gmail address/password combinations.

    All other plugins are disabled (the only one previously enabled was reCaptcha).

    When I try to send a test message, I get "Test Result" with no additional text, and a "return to options" button. No test message is ever received.

  8. grantwp3
    Member
    Posted 4 years ago #

    Forgot to include the following info:

    Accessing WP interface via Firefox 3.5.3 on Mac OS X 10.4

    WordPress hosting is with bluehost.com

  9. amlansarma
    Member
    Posted 4 years ago #

    The test message doesnot get delivered.I have subscribe2 plugin installed in my blog.When I try to send emails to subscribers this message comes up-

    "Message failed! Check your settings and check with your hosting provider
    SMTP Error: Could not connect to SMTP host."

    Can you suggest anything?

Topic Closed

This topic has been closed to new replies.

About this Topic