WordPress.org

Ready to get started?Download WordPress

Forums

HeadSpace2 SEO
%%title%% Gets the same title on all the posts (4 posts)

  1. phattrance
    Member
    Posted 2 years ago #

    Does anyone know why my mobile version of blog gets the SAME title on the posts when i have added the "%%title%%" string. It should give the post title but somehow its just stuck to only one title. Note that this works on the blog, its just the mobile version thats messed up!

    You can find a screenshot here: http://i.imgur.com/vSzOi.jpg

    Mobile site version: http://funny-pictures-blog.com/m.php
    Blog URL: http://funny-pictures-blog.com

    http://wordpress.org/extend/plugins/headspace2/

  2. zagued
    Member
    Posted 1 year ago #

    I have the same problem but not only on mobile browsers. It's everywhere.

    For some reasons, all the posts have the same title. I don't even understand the logic of picking this particular title (one of the posts). I can't override the title by updating it in the post directly.

    Here are examples:

    http://www.anitawhelan.com.au/yoga-therapy/
    http://www.anitawhelan.com.au/sundays-learn-breathe-workshop/

    They have all the same title as this post:

    http://www.anitawhelan.com.au/massage-part-1/

    Why?!?

    What's wrong?!

  3. zagued
    Member
    Posted 1 year ago #

    My config:
    - Theme Unite v2.0.2
    - HeadSpace2 v3.6.41

    I need to enable Force Title Rewrite to make the plugin work:
    - it work fine when i set up the title and description at the page level (even when using shorname like %%title%%)
    - but it stops working as soon as i enable a generic setting in the Page Settings screen: if i do so let say for Pages, all the pages will have the same title (a random one out of all the existing pages).

    It seems like it's an issue with generic settings force rewrite cache.

  4. zagued
    Member
    Posted 1 year ago #

    Alright, it's all good, i found the answer to my issue here:

    http://urbangiraffe.com/plugins/headspace2/faq/

    I have updated my header.php with as below:

    <title><?php wp_title(''); ?></title>

    Then disable the force rewrite. And everything worked fine!

    Thank you for the great plugin!

    Cheers,
    Zag.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags