WordPress.org

Ready to get started?Download WordPress

Forums

  1. Cristiano
    Member
    Posted 2 years ago #

    I get this error:

    jPlayer 1.2.0 : id='haiku-player1' : Error!
    
    Problem with Flash component.
    
    Check the swfPath points at the Jplayer.swf path.
    
    swfPath = http://www.munirhossn.com/wp-content/plugins/haiku-minimalist-audio-player/js/
    url: http://www.munirhossn.com/wp-content/plugins/haiku-minimalist-audio-player/js/Jplayer.swf
    
    Error: a._getMovie().fl_setFile_mp3 is not a function

    Any idea?

    http://wordpress.org/extend/plugins/haiku-minimalist-audio-player/

  2. phpadam
    Member
    Posted 2 years ago #

    I get the same error.

    Ever get a resolution?

  3. zbacsi
    Member
    Posted 2 years ago #

    Same error, but not with all themes. I think it depends on the theme, or the scripts used by the theme.
    Anyway, I don't understand why Haiku player needs flash. Isn't it an HTML5 player? It could be work only with javascript and css.

  4. zbacsi
    Member
    Posted 2 years ago #

    Hmm... there is no error message if Firebug is disabled.

  5. ctctc
    Member
    Posted 2 years ago #

    I have 1 person who experiences this error on my site when all other users don't have a problem. I wish that I could fix this error for him but I don't know how. Any Ideas?

  6. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    This error is often caused by Firebug. You might also see it if you've got a Flashblocker running or if you have javascript errors in your theme.

    The plugin defaults to Flash and falls back to HTML5 on browsers that don't support Flash like Mobile Safari. HTML5 audio support still isn't universal (no MP3 in Firefox, not at all in older versions of IE) so Flash is still in use by default. The two important things for me in designing this plugin: 1) works on iOS and 2) clean design that can easily be modified with HTML & CSS.

  7. khyams
    Member
    Posted 2 years ago #

    I ran into the same issue when using Haiku inside Fancybox. Disabling Firebug and restarting Firefox works the first time that I access the player. But when I close the Fancybox link and re-open it, that error reappears.

    I'm using Firefox 10.0.2. I do not run in to this issue when testing in both Safari and Chrome.

  8. nickles2u
    Member
    Posted 2 years ago #

    Running Firefox 10.0.2 and still had the error even after disabling Firebug. Re-enabled and disabled AdBlock Plus 2.0.3 and all is well on the Mac side (haven't tested on the PC).

  9. khyams
    Member
    Posted 2 years ago #

    Have you tried to play the track multiple times in one page view? That's where I run in to issues...

  10. nickles2u
    Member
    Posted 2 years ago #

    Yes, I did as well. Once AdBlock was gone all was weel with the world. I've downloaded the Adblock Diagnostics to see what it shows, but haven't looked further yet.

    What platform are you on? What's your link? Want to try mine and see if you're getting problems?

    nickchapin.com

  11. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    Please let me know if you find out anything about AdBlock. I'll do some testing too. I would love to find a workaround if this could with plugin compatibility.

    Dalton

  12. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    I have tested the latest version of FFX & Adblock on all of our demo pages with no problems. I wonder if this has to do with particular filter lists or URL matches on the media files themselves?

    If either of you can upload the MP3 files to another site, does the behavior change?

    Dalton

  13. khyams
    Member
    Posted 2 years ago #

    Unfortunately I cannot disclose the site URL, but this is what I'm working with:

    • WP 3.3.1
    • Mycorptheme with minor tweaks (multiple custom post types, page templates, etc.)

    I've uploaded an MP3 file to my personal website and still receive an error message. But this part of the message – "Error: ***** is not a function" – is different than the error that I receive when the MP3 file is on the site that I'm working on.

    MP3 file on personal site
    Error 01

    MP3 file on current site
    Error 02

  14. nickles2u
    Member
    Posted 2 years ago #

    Kyhams: I was getting the same error you're getting on the personal site (same as the graphic at the top of this thread).

    Dalton & Kyams: I apologize. After further testing it wasn't AdBlock. It seems that the error (for me) appears almost never on the initial page load. On refreshing the page it rarely happens the second refresh, more frequently on the third, and always by the forth refresh.

    After looking more at the actual error and knowing that the Google site translator widget uses Flash I tried that route. Removed the widget. I've loaded, refreshed, restarted, cleared the cache, didn't clear the cache, everything I can think of many many times. Now I'm not getting an error.

    Really never, this time. (Sorry about that!)

    Are either of you using the Google Translate widget? Any other flash bits on your page?

    Nick

  15. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Nick,
    What other browsers have you tested in? Just curious to know if this was happening in other browsers or just Firefox. (Firefox has always been a little bit of a problem with this plugin, since it doesn't support HTML5 MP3 natively that's why we need to enable Flash fallback in the player)

    I personally don't use any Flash add ons on any of my sites, maybe that's why I've almost never come across this error in my testing.

    I also think if you've got any other heavy javascript slowing down the page it could cause a problem. I always start in the default theme, no plugins, and work my way up one by one until I find which one is causing the problem.

  16. khyams
    Member
    Posted 2 years ago #

    Nick,

    I am not using Google Translate.

  17. nickles2u
    Member
    Posted 2 years ago #

    Dalton: I've tested in Safari, Chrome, and Firefox (all latest revs) on OSX 10.6.8. I've tested on Windows Vista in the same three browsers plus IE and had no issues with the widget installed. I only have issues on the Mac with Firefox with the widget installed.

    I do not have any other Flash stuff, but do have a number of js scripts running. I'm running a child of Suffusion. I'll try to do some more testing offline with the default theme and work up from there. (Probably not today, though.) When I find something I;ll let you know. Other than that, great plugin!

    Thanks!

  18. rookiecop
    Member
    Posted 2 years ago #

    I also have the Firefox problem where the audio will not play

    The play button changes to pause when clicked but there is no sound. There is no error message. Neither Firebug nor Ad /Flashblocker or Google Translate are installed & Ive tried disabling just about everything including all my WordPress plugins (including theme changes). I have tested using Haiku 0.4.5 with no modifications and am using WordPress 3.3.1 twentyeleven theme & Firefox 11. Like I say everything works fine in all other browsers.

    url is rookieloops.co.uk

    Thanks a lot

    Col

  19. wolfkain
    Member
    Posted 2 years ago #

    Just replace Line 34 in haiku-player.js:
    $("div.haiku-text-player").jPlayer("stop");

    with this code:

    if($.browser.mozilla) {
        $("div[id^=haiku-text-player]").each(function() {
            if($(this).is(":visible")) $(this).jPlayer("stop");
        })
    } else {
        $("div.haiku-text-player").jPlayer("stop");
    }

    works perfect on Firefox and doesn't break anything on other browsers!!!

  20. Master Devwi
    Member
    Posted 2 years ago #

    I'm having an issue with this error as well. But, unlike everyone else, this problem is only in the Metro version of Internet Explorer 10, which disables add-ons. Of course, it's possible that this is a glitch in the Windows 8 Consumer Preview and that it will be fixed in the Release Preview or the final shipping version.

  21. Master Devwi
    Member
    Posted 2 years ago #

    Update: The problem actually occurs in both IE10 Metro and Firefox (as with everyone else). Firebug is also disabled.

    Here's the website, for reference: http://radiofilms.com. This is the only plugin I have enabled, and the theme is called "Titanium Folio."

  22. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    Wolfkain's update appears to be the most promising fix for this issue. We're in the process of overhauling the plugin, including an update to the latest version of jPlayer, and we're testing Wolfkain's fix for inclusion.

    Can't say for the Windows 8 problem, we won't be able to test that until the final version is released. But since IE10 should support HTML5 audio by default, we should be able to turn off the Flash requirement for that version.

  23. Master Devwi
    Member
    Posted 2 years ago #

    Thanks for the quick response, Dalton. Unfortunately, I couldn't get Wolfkain's solution to work in IE10 or Firefox. I did, of course, attempt to change the if statement to work with IE.

    I've also been informed that the error appears on the desktop version of IE10 when Flash isn't installed.

    I'm glad to hear that there's an update coming, because I think this is a fantastic plugin.

  24. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Master Devwi,
    Can I ask a small favor? I've never actually been able to reproduce the problem in Firefox on any of my sites, so I still technically don't know what's causing it. I wonder if you can test one of the audio players on this page in IE10:

    http://storycorps.org/listen

    And see if you experience the same problem? I have never experienced the Firefox bug on this site, which receives 100k + visitors a month.

    I would really appreciate it.

    Dalton

  25. Master Devwi
    Member
    Posted 2 years ago #

    Yeah, it works great on your site. My site's theme must be causing some sort of conflict, then.

  26. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    One thing I notice about your theme right off the bat, it's loading a script called "jquery-1.4.1-and-plugins.min.js. That means you've got an older version of jQuery loading, and jQuery is loaded twice, because our plugin loads it too.

    WordPress has a feature called enqueue_scripts that's supposed to prevent this from happening, but I guess your theme developer didn't use it. Combining jQuery with other scripts like that is also bad form.

    You may be able to work around this by adding the following to your theme's functions.php:

    <?php add_action('init', 'remove_jquery');
    
    function remove_jquery() {
     wp_deregister_script( 'jquery' );
    } ?>

    This should remove our version of jQuery, leaving only the version loaded by your theme. It's a workaround (the theme should really be fixed) but it could work.

    Dalton

  27. Master Devwi
    Member
    Posted 2 years ago #

    Thanks Dalton! I guess I'll have to add that to the list of bugs to send to the theme developer.

    I tried adding the code to functions.php, but it didn't seem to fix the issue. Of course, it's possible I added it incorrectly. I tried it in a few places to no avail.

  28. Master Devwi
    Member
    Posted 2 years ago #

    I'm having the same error in the Windows 8 Release Preview (which has a limited version of Flash built into IE10), so I guess I'll have to see what I can do about fixing the theme or contacting the developer (who doesn't seem to respond to customers anymore).

  29. renessacb
    Member
    Posted 2 years ago #

    Hi all- I am having some trouble here, not specific to just Firefox. The player was working fine for me for the past week i have been using it, but all of a sudden today it's not working anymore : (

    http://komatoast.com/testing/new-knobbs-album-has-arrived

    Your input would be appreciated! I need to get this site finished so if I can't resolve easily I'll have to find another MP3 player solution. Thank you!

  30. Dalton
    Member
    Plugin Author

    Posted 2 years ago #

    If it was working before and isn't anymore, that sounds like a conflict with another plugin. Try disabling them one at a time until you find the culprit.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic