WordPress.org

Ready to get started?Download WordPress

Forums

Gurken Subscribe to Comments (deprecated)
[resolved] [Plugin: Gurken Subscribe to Comments] Configuration gets deleted and replaced by "a" ever (5 posts)

  1. Tobias Jordans
    Member
    Posted 3 years ago #

    I am in the process of moving our blog http://www.uxzentrisch.de to a new host europe server.
    I get this strange bug that replaces all settings for "Gurken Subscribe to Comments" with "a"s.

    See this small screencast to see the error: http://screenr.com/1re
    It works fine for "asdf"-strings but breaks as soon as I put my old configuration "Du bist der Autor dieses Beitrags. Einstellungen ändern." in the "Entry Author" field.

    We testet unserializing the settings but this returned false. So at some point the serialized objects gets corrupted?

    Any thoughts?

    Those are my host europe php-settings:

    Einstellung Status
    PHP-Errors Im Browser ausgeben ändern
    PHP-RegisterGlobals Off ändern
    PHP-mbstring.func_overload Wert 7 ändern
    PHP-allow_url_fopen On ändern
    PHP-allow_url_include On ändern
    PHP-Magic-Quotes-GPC On ändern
    PHP-Zend-ZE1-Kompatibilität Off ändern
    PHP-Register-Long-Arrays Serverstandard ändern
    PHP-Session-Use-Trans-SID Serverstandard ändern
    PHP-Allow-Call-Time-Pass-Reference Serverstandard ändern
    PHP Suhosin Executor Allow Symlink Serverstandard ändern
    PHP Suhosin Session Encryption Serverstandard ändern
    PHP Suhosin Mail Protection 1 ändern
    PHP Suhosin RPG Max Vars Serverstandard ändern

    Thanks a lot
    Tobias

  2. infogurke
    Member
    Plugin Author

    Posted 3 years ago #

    It's working on my hosteurope server, but it's a dedicated one ;-)

    Try to disable magic quotes. It's really bad:
    http://www.php.net/manual/en/security.magicquotes.whynot.php.

    Maybe you shouldn't use my fork at all. I reviewed Subscribe To Comments Reloaded and it's working fine, well-maintained, nice code (compared to the original subscribe to comments plugin) and it has more features.

    Greetings
    Martin

    BTW: It's a security risk to have allow_url_include enabled.

  3. Tobias Jordans
    Member
    Posted 3 years ago #

    Thanks, "Subscribe To Comments Reloaded" looks very nice and there is no error.

    Maybe you should make the switch to the new plugin officials by referring to the new plugin from your plugin-page?

    Thanks for you help - also for the security-advice
    Tobias

  4. camu
    Member
    Posted 3 years ago #

    Hi all,

    first of all thank you Martin for your kind words. I'm glad you liked what I've done. I can confirm the plugin is actively maintained and supported, and I should be able to release a new version as soon as I'm done upgrading my other plugin, WP SlimStat, which will soon include commenters' tracking and a lot of bugfixes and improvements.

    Camu

  5. FolioVision
    Member
    Posted 3 years ago #

    We've got Gurken Subscribe to Comments working just fine across five different servers, several dedicated and several shared, under WordPress 3.1.2.

    Before installing camu's plugin as a replacement for Mark Jacquith's Subscribe to Comment or Gurken Subscribe to Comments, you might want to read carefully this Subscribe to Comments Reloaded discussion.

    We ended up almost getting banned from several major email ISP (Yahoo, EarthLink) for sending out emails to spam addresses. Plus despite claims to the contrary, there is no reverse compatibility or migration path back to Gurken or Mark Jacquith's plugins.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic