WordPress.org

Ready to get started?Download WordPress

Forums

GT Tabs (formerly postTabs)
[Plugin: GTTabs (formerly postTabs)] First tab displays, content does not show in subsequent tabs (15 posts)

  1. druvia
    Member
    Posted 2 years ago #

    I can't seem to get the tabs to work properly.

    The first tab shows its contents fine but all subsequent tabs are blank. If you could help with some direction on what I'm doing wrong, I would be so grateful.

    http://wordpress.org/extend/plugins/gt-tabs/

  2. druvia
    Member
    Posted 2 years ago #

    [Smacks head] There was a stray div in there that was wreaking havoc! It works beautifully now. Thanks for a great plugin.

  3. Diomenas
    Member
    Plugin Author

    Posted 2 years ago #

    @Druvia,

    Was the stray <div> tag a part of your code or a stray code found within my plugin?

  4. nigellouw
    Member
    Posted 2 years ago #

    Hi

    I have added GT Tabs to my site in WP3.1.2.

    It works great in Fire Fox but the content in the tabs is blank in the latest IE.

    How can I fix this?

  5. Diomenas
    Member
    Plugin Author

    Posted 2 years ago #

    @nigellouw: I have tested this plugin in various platforms including IE 9, Opera 11.1, Firefox 4, Safari 5.05, and Chrome 11.0 and have not seen any issue with tab content not being displayed. The website that I personally have made that includes the tabs plugin is http://www.lazerworkz.com as well as bookfieldcreativeminds.com/.

    Can you please advise as to what other plugins you are using in conjunction with GT Tabs as well as provide a link to your website so I can inspect the source to see what could be causing this issue? Also, have you tried disabling all add-ons for IE9 to see if you still get the same error?

  6. nigellouw
    Member
    Posted 2 years ago #

    Thanks for quick reply Diomenas

    My website is http://www.fishandstay.co.za

    The tabs I am testing are on post http://www.fishandstay.co.za/?p=164

    Plugins used are:
    Akismet
    cforms
    Content Slide Plugin
    Custom sidebars
    Image Widget
    jQuery Vertical Accordion Menu
    NextGEN Gallery
    WP125

  7. nigellouw
    Member
    Posted 2 years ago #

    Disabled all IE9 add ons and still no content showing. Maybe I should disable all plugins and see if it works then.

  8. Diomenas
    Member
    Plugin Author

    Posted 2 years ago #

    It looks as if the tab data is loading but for whatever reason when you try to change tabs, IE9 is not catching the display css changing. This appears to be isolated to IE9 and may be an interaction with some of the other plugins possibly causing a conflict. However, it can be resolved by clicking on 'compatibility view' to switch to 'older browser compatibility'. Unfortunately, Microsoft doesn't make it very easy to program for Internet Explorer because they seem to make major changes with every version they release, and those changes make some sites that worked previously on older versions cease to function... not a very clean way to do things. I will work to see if i can resolve the issue and release this in a future update.

  9. Diomenas
    Member
    Plugin Author

    Posted 2 years ago #

    By the way, very nice site design. I really like seeing how people utilize my plugin.

  10. nigellouw
    Member
    Posted 2 years ago #

    Thanks. Compatibility view works. Please let me know as soon as you have a fix as everybody with IE9 won't be able to see the content unless they use compatibility view, but most people won't even know what that is.

  11. nigellouw
    Member
    Posted 2 years ago #

    Hi

    When do you think you will be able to have a fix for that issue in IE9?
    I want to launch the site soon, but will lose clients if they on IE9 and can't see the content.

  12. nigellouw
    Member
    Posted 2 years ago #

    I got it sorted. The older version post tabs works perfectly.

  13. digiblogger
    Member
    Posted 2 years ago #

    Hello,

    i use firefox and latest plugin/wordpress and have the same problem.

    Tabs are shown, but text after [tab:second tab] is shown on tab1 and other tabs are not selectable...

    Can you please help

  14. digiblogger
    Member
    Posted 2 years ago #

    I use the former version so far. it works great indeed.

  15. Diomenas
    Member
    Plugin Author

    Posted 2 years ago #

    I have found that jQuery Vertical Accordion Menu seems to create strange issues with a lot of plugins. Can you please try disabling this plugin and advise if this resolves your issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags