WordPress.org

Ready to get started?Download WordPress

Forums

GTS Translation Plugin
[resolved] Machine translated pages give 404 (7 posts)

  1. onlineous
    Member
    Posted 2 years ago #

    Hello,

    I´ve just started using the plugin on my website http://www.perfectperu.info

    When I update my pages I get emails confirming that the page has been translated. However, when I try to look at this page I get 404 errors stating the pages are not availabe.

    Do you have to review the machine translated pages before they are visible on the website? I tried that with a few page's but they don't appear as either.

    I hope someone can help me with this problem.

    Thanks in advance!

    http://wordpress.org/extend/plugins/gts-translation/

  2. onlineous
    Member
    Posted 2 years ago #

    Some small additions:

    the posts don't show up in manage posts in the dashboard as well. How long does it take for a translation to be available normally?

  3. sergeyvlasov
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hello onlineous!

    My name is Sergey, and I'm trying to provide support to the plugin in my spare time ;)

    Can you tell me please, whether your site is accepting machine translated content? It's a check box near the bottom of 'GTS Settings' page.
    Additionally, try to check out whether there are posts waiting for approval. In order to do this, go to 'Manage Posts' page and click the link near the top of the page, with 'GTS Website' anchor text.

    Tell me please what do you see and any additional questions you have!

  4. onlineous
    Member
    Posted 2 years ago #

    Yes the 'Display machine-translated content?' is checked.

    I don't have posts, I only have pages.

    Normally when I make a page it shows up on the GTS website with status 'Machine Translated'. When I hit, 'Check out' on the right, this box changes to 'Review'. When I hit review I get an editor. When edited it goes to status 'Reviewed'. However, the reviewed posts don't show up translated on the website.

    This link should go to a translated (deutsch/german) website:
    http://perfectperu.info/?p=1799
    Strangely enough it ends up on the english variant. When I try to use the widget to translate to german I get a 404.

  5. onlineous
    Member
    Posted 2 years ago #

    Found out anything yet?

  6. davegrun
    Member
    Plugin Author

    Posted 2 years ago #

    Dear onlineous!

    We have forwarded this issue to our developers. We will let you know once it is resolved.

  7. onlineous
    Member
    Posted 2 years ago #

    I found the sources of the problem. I had the 'local landing pages' plugin enabled.
    I found out that was the problem when I tried to autotranslate using google translate. I got a redirection error and that brought me to 'local landing pages'. I disabled the plugin and the translations work now!

    Thanks for trying to help me!

    Best regards,

    Jaco Hollebrandse

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic