WordPress.org

Ready to get started?Download WordPress

Forums

Greg's High Performance SEO
[resolved] Gregs SEO doesn't play nice with sharethis plugin (12 posts)

  1. soultrader67
    Member
    Posted 2 years ago #

    SEO works well until I tried to use Sharthis plugin. It seems that the SEO plugin doesn't like it and stops the social icons from showing on my theme Striking? Everything else works

    http://wordpress.org/extend/plugins/gregs-high-performance-seo/

  2. GregMulhauser
    Member
    Plugin Author

    Posted 2 years ago #

    This sounds very much like a theme issue, since GHPSEO does its best not to interfere with anything.

    If you're still convinced it is GHPSEO itself that is stopping your social icons from showing -- rather than theme coding -- I'd recommend using a different SEO plugin.

    All the best,
    Greg

  3. adrenalis
    Member
    Posted 2 years ago #

    soultrader, I have the same problem, and it isn't a custom theme. Fill in the secondary title and head description in order to get your icons to show. A pain, but it works. I will play around in the GHPSEO menus tonight and see if there is a way to correct this without going back and having to fix pages/posts individually.

  4. soultrader67
    Member
    Posted 2 years ago #

    Thanks adrenalis. I thought Greg might have been mistaken 8-) I will have a play around with this solution over the weekend.

  5. soultrader67
    Member
    Posted 2 years ago #

    Adrenalis, does this need to be done for every page?

  6. altfgcom
    Member
    Posted 2 years ago #

    I'm having the same problem. Once I activated Greg's High Performance SEO plugin a few minutes ago, the ShareThis icons disappeared from individual posts -- though they have remained in place on the home page.

    I'm sure all this needs is some minor tweaking, but what??

    Any assistance would be greatly appreciated...

  7. altfgcom
    Member
    Posted 2 years ago #

    Following adrenalis' advice, I've filled in the secondary title description (no need for head description) for one post.

    Voila! ShareThis buttons were back -- but for that one post ONLY.

    We have nearly 8,000 posts. Oy...

    (I've also emptied the SuperCache cache. No luck.)

  8. altfgcom
    Member
    Posted 2 years ago #

    Solution:

    Instead of choosing "automatically add ShareThis icons/buttons to your posts," choose NO.

    Then manually insert the ShareThis html code (it's right there on the ShareThis plugin page) where you want it to go in your single.php file.

    Pretty simple, really.

  9. GregMulhauser
    Member
    Plugin Author

    Posted 2 years ago #

    Hi folks,

    Glad to see this resolved. I've added this topic to the plugin FAQ, explaining what can happen when other plugins try to use WordPress filters to do a theme's job (i.e., relying on filtering the_content to position content on the page instead of using a template tag).

    All the best,
    Greg

  10. adrenalis
    Member
    Posted 2 years ago #

    Thanks, Greg

  11. adrenalis
    Member
    Posted 2 years ago #

    altfgcom, I am at work and so I can't fool around with this right now, but I am wondering: are you using multisite? If so, can you check and see if your theme mod creates errors on sites that don't have sharethis enabled? I know I am not contributing much to this thread; my apologies... they are killing us at work this month.

  12. altfgcom
    Member
    Posted 2 years ago #

    Sorry, adrenalis, I can't help you there as I'm not using multisite.
    When you get some free time, try inserting the ShareThis code manually. Hopefully that'll work for you as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic