WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Great Real Estate] New Plug-in version for WP 2.9 and up??? (12 posts)

  1. bamajr
    Member
    Posted 4 years ago #

    I'm interested in your plug-in, but it seems development stopped at WordPress 2.8.2 and now we are up to 2.9.2

    I'm using WordPress 2.9.1 at this time, but will soon be upgrading to 2.9.2, but your plug-in has the compatibility warning:

    "Warning: This plugin has not been tested with your current version of WordPress."

    Due to the version compatibility stopping with WordPress 2.8.2 I'm guessing.

    http://wordpress.org/extend/plugins/great-real-estate/

  2. Ovidiu
    Member
    Posted 4 years ago #

    right, any plans to update the plugin?

  3. Mindshare Studios, Inc.
    Member
    Posted 4 years ago #

    It seems to work with 2.9.2 except I'm having some weird jQuery issues on the WP admin pages. For example, if Great Real Estate is activated and you go to edit a Post or Page you cannot toggle any of the post boxes (Attributes, Custom Fields, etc). This pretty much renders the plugin useless until these bugs are squashed.

  4. Mindshare Studios, Inc.
    Member
    Posted 4 years ago #

    I think I fixed the issue. Simply replace the jQuery Validation plugin the is bundled with Great Real Estate with a more recent version:

    http://ajax.microsoft.com/ajax/jquery.validate/1.7/jquery.validate.js

    And everything should be working again. I need to do some more testing but so far this seems to do the trick.

    The file to replace is here:
    great-real-estate\js\jquery.validate.js

  5. girark
    Member
    Posted 4 years ago #

    I am using plugin version 1.3.1 with WordPress 2.9.2, and I am also having issues. When I click "Create a Listing" I get the standard page form, but changing the Main Page to my listings page doesn't give me any new fields or anything like that.

    I have updated the jQuery plugin...is this a compatibility issue or am I missing something fundamental?

    Thanks,
    Ken

  6. girark
    Member
    Posted 4 years ago #

    Please ignore that last post. The problem wasn't the fields - those appeared below (the preview showed them in the 'edit page' box itself).

  7. Roger Theriault
    Member
    Posted 4 years ago #

    @mindshare, I'm updating that file in 1.4 which should be available on Extend any moment now. That and a few links seem to be the only issues for 3.0 (excepting any third party plugin changes, of course).

    Thanks for pinpointing the issue.

  8. Roger Theriault
    Member
    Posted 4 years ago #

    @bamajr - the compatibility warning goes away when enough people chime in on Extend saying whether the plugin works. Also, given that 2.9 had no breaking issues, I didn't update the readme.txt file, which is part of the warning logic apparently.

    Anyway, @everyone - a new 1.4 release is out. Please report any issues here or in my forums. And if it works, please go to the plugin page and click "Works" for your config to help other users out.

  9. mpvanwinkle77
    Member
    Posted 4 years ago #

    Roger, this is not working for me. I can't get to the listing page, it just takes me to the standard page entry form.

  10. mpvanwinkle77
    Member
    Posted 4 years ago #

    Ugh. Disregard. I figured it out. Once I saved the page the property info shows up. From a usability standpoint it's a little confusing. But it works.

  11. mpvanwinkle77
    Member
    Posted 4 years ago #

    Ugh. Disregard. I figured it out. Once I saved the page the property info shows up. From a usability standpoint it's a little confusing. But it works.

  12. bamajr
    Member
    Posted 3 years ago #

    @Roger Theriault - apparently there are two spots where the compatibility of a plug-in is identified. Also, any one who uses the "Better Plugin Compatibility Control" plug-in on their WordPress site will identify this issue.

    Your readme.txt file shows:

    Requires at least: 3.0
    Tested up to: 3.0

    If you have tested it this plug-in upto 3.0.1, it should read:

    Requires at least: 3.0
    Tested up to: 3.0.1

    Just an observation: If this would have been done correctly, it may not have taken so long for the compatibility to update on the WordPress Plug-ins Directory.

    Before you ask, I do know where to change this at, but it is a hassle. A bunch of plug-in developers seem to forget this one little spot.

Topic Closed

This topic has been closed to new replies.

About this Topic