WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Salesforce Add-on
Multi-select and file upload issues (3 posts)

  1. Unclesabre
    Member
    Posted 2 years ago #

    Hi all,

    I'm having a few challenges getting GF to send all the data I need to Salesforce. I'm creating a pretty complicated job application form and using GF to replicate one I hand coded previously.
    My issues are:
    1. I need users to select all the areas they're happy to work. This is a standard multi-select list (<select>) which is sent to SF as an array. In my custom version I do some php processing to send all the choices with the variable name so it becomes something like this &geochoice=choice1&geochoice=choice2&geochoice=geochoice3 etc... we don't know how many areas the user will choose so I can't figure out a way to do it in GF and it's driving me nuts. This must be a common problem but I couldn't find a solution.

    2. The users can upload their CV (which gets stored on the wordpress server). I want to send the url link to SF so the admin can click on the link and see the CV (from the WP server). However, the link isn't being sent - anyone got any tips why this might be?

    Going slightly bonkers trying to sort this out so any help would be much appreciated!
    Thanks,
    James

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

  2. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    Multi-select should be fixed in version 1.1.2 - please confirm that this fixes the issues. Thanks for reporting!

    In terms of uploads, sorry, that didn't make it into the testing round - too busy! Next round perhaps!

  3. Unclesabre
    Member
    Posted 2 years ago #

    Thanks for the reply Zack. I've been away skiing for a week so sorry for slow reply.

    In the end, I was having such a nightmare with GF->SF that I reverted back to my hand-built form processor which does some pre-processing before sending the data to SF.

    It's not the slick solution I wanted but (hopefully) it works.

    Cheers,
    James

    Ps. I have a different issue with another form so will start a new thread if I can't fix it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic