WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms iContact Add-on
[resolved] Welcome Message/Confirmation (7 posts)

  1. jlindo
    Member
    Posted 1 year ago #

    Hello,

    When I test the sign up contact forms provided by iContact, my auto-responder welcome message confirmation is triggered and email to the user.

    However, when I use this plugin the user is added to my list but no welcome message is sent.

    Is there a way to enable this? Any help is greatly appreciated!

    Thanks,
    Jared

    http://wordpress.org/extend/plugins/gravity-forms-icontact/

  2. Dawud Miracle
    Member
    Posted 1 year ago #

    Having same problem.

    When I compare the form HTML generated by iContact and that by GF, I find a few hidden fields missing. I spoke with iContact and was told that the hidden field for double opt-in was required to start the confirmation process (and the autoresponder).

    Here's the code for that:

    <input type="hidden" name="doubleopt" value="1">

    value=1 creates the double opt-in (sends confirmation message/autoresponder).

    I tried adding this as an HTML block in GF. While the code rendered in the GF form, it didn't pass it to iContact. Guessing there needs to be a field to map for this to work correctly.

    In the iContact Feeds setup there is a form field for doubleopt in the drop down but it doesn't have a list field to map to to.

    This function is pretty important to making this plugin work correctly for most users. Anyhow doing email list marketing should be using double opt-in. So can we find a way to solve this?

  3. Dawud Miracle
    Member
    Posted 1 year ago #

    Hey Zack

    Any movement on this post? Wondering if it's at least on your radar.

  4. Dawud Miracle
    Member
    Posted 1 year ago #

    Hi Zack

    I do hope everything is okay on your end.

    The need here to have your plugin work correctly with GF and iContact. It's much bigger than my own need - it's really a need of anyone who would use double opt-in - which your plugin doesn't correctly handle.

    Could you please look into this?

  5. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    I don't believe the API provides a way to enable or disable double-optin. I've requested they get back to me on that.

  6. Dawud Miracle
    Member
    Posted 1 year ago #

    Hey Zack.

    Any word from iContact on this?

    I don't think we need to 'enable double-optin' as much as trigger it. I have to image the API will trigger double-optin as it's a major part of email marketing.

    The trouble here is - as I've spoken with them - is that they tie their autoresponder service to a verified optin. Without double optin there's no way to trip their autoresponder - from they told me. If you can find a work-around, great.

    Also, you could confirm my earlier post with them about this hidden field turning on double-optin:

    <input type="hidden" name="doubleopt" value="1">

    If it does, can't you simply add that into the plugin on your end and see if the API captures it and passes it through to the iContact account?

    If that's the case, then couldn't you just write the plugin to toggle whether the hidden field publishes to the form the plugin creates or not? As long as the API will pass the hidden field and trip the double-optin process then it doesn't really matter, it would seem, how the hidden field gets included.

    Just a thought.

  7. Austen Blokker
    Member
    Posted 11 months ago #

    I was having the same problem with my welcome message. I got it to work by editing my welcome message in iContact and checking "Automatically send a Welcome Message when: I add a contact (One-At-A-Time)". This will cause your welcome message to send when the contact is added through the iContact API.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic