WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Highrise Add-on
[resolved] Tags don't work (17 posts)

  1. smerriman
    Member
    Posted 2 years ago #

    A field with label 'tags' as mentioned on the settings page doesn't work at all.

    If you look at the getLabel function in highrise.php, the line of code that turns a label into 'sTags' is missing entirely. I presume there should be something like:

    else if ( strpos( $the_label,"tags") !== false) {
    	$label = 'sTags';
    }

    http://wordpress.org/extend/plugins/gravity-forms-highrise/

  2. smerriman
    Member
    Posted 2 years ago #

    The plugin also says that any field it can't determine is added to 'Staff Comments'.. again, comparing this plugin to previous versions it looks like it used to do that, but that code got deleted too like the above code (which used to exist).. in fact, adding a field it can't match seems to prevent any data getting through at all.

  3. lhutt
    Member
    Posted 2 years ago #

    I have both of these problems too and I am using the latest version of both GF and the Highrise Plugin

  4. sterlingokura
    Member
    Posted 2 years ago #

    Same problem here. Did tags used to work on previous versions?

  5. lhutt
    Member
    Posted 2 years ago #

    I have never been able to get it to work since I first found out about the plugin 6 mos ago.

  6. strangebiscuit
    Member
    Posted 2 years ago #

    Ahh! Everything else works perfectly for me with this plugin but the tags feature is a deal breaker.

    We need to be able to easily categorize contacts in Highrise and tags are the best way to do that. Only other option is to add custom fields as category labels and manually type in category names in the contact filter. Much easier to just click on a tag.

    Plugin is otherwise terrific, but without tagging it's crippled.

  7. martinog
    Member
    Posted 2 years ago #

    This plugin appears to work fine if you have only one Gravity Forms form. When you have more than one form, it appears to not like duplicate label names.

    I also run their Directory Plugin so that makes it a show stopper. If this plugin read fieldids rather than just the field labels, and there was some way of mapping tags to field labels, that might resolve the issue. It read my Phone number, Email, Company Name and Address and it did not appear to be case sensitive.

    I disabled the other Highrise forms but that didn't solve the problem.

  8. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    The tags are now fixed and you can use Parameter Names to define any field as tags (such as the nice "List" field type). Here's how: http://wordpress.org/extend/plugins/gravity-forms-highrise/faq/

    Sorry for the issues; please let me know how this works for y'all.

  9. daser007
    Member
    Posted 1 year ago #

    I must be doing something wrong. I have latest version 5 installed and data is passing to Highrise fine. However tags are not being added. I went to the FAQ to follow the link you posted for "Here's how" but didn't find anything. Please help me make the tags work.

  10. daser007
    Member
    Posted 1 year ago #

    Never mind it works now :) thks!

  11. webicycoffee
    Member
    Posted 1 year ago #

    I'm still having an issue with tags not making it over to Highrise. All the other fields work fine.

    I'm using version 2.5 of the Highrise Plugin, Gravity Forms 1.6.5.1 with WordPress 3.4.1. Just adding a hidden filed called 'tags' with a single value. What's everyone else using?

  12. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    Try using sTags instead.

  13. webicycoffee
    Member
    Posted 1 year ago #

    Hey Zack,

    Thanks for the quick response! I tried sTags, but still no tags in Highrise.

    I also tried moving the hidden field's position in the form without success. Any other troubleshooting tips?

  14. webicycoffee
    Member
    Posted 1 year ago #

    Hey Zach,

    I've tried tags, sTags and adding both to hidden fields, but the tags never make it in to Highrise.

    http://i47.tinypic.com/ieozyf.png

  15. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    @webicycoffee - let me know if this works now with version 2.5.1.

  16. webicycoffee
    Member
    Posted 1 year ago #

    Hey Zach,

    That update has addressed the issue. Both 'tags' and 'sTags' are working great!

    Thanks so much for your help with this.

    Cheers!

  17. sterlingokura
    Member
    Posted 1 year ago #

    Yay. Zack, thank you sir!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic