WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms CapsuleCRM Add-on
[resolved] Carlos (12 posts)

  1. hippoc
    Member
    Plugin Author

    Posted 2 years ago #

    From Carlos

    Thanks for creating this plugin. We were hoping for this! We installed the plugin and followed the instructions for setting it up. Everything on the setup side looks good - green checks, etc. However when we test a gravity form submission - and then go into our capsulecrm account to see if it transferred the capture - we do not see this new data.

    Any thoughts on what we are doing wrong or can do to get this implemented? Please advise and thanks!

    Carlos

    http://wordpress.org/extend/plugins/gravity-forms-capsulecrm-add-on/

  2. hippoc
    Member
    Plugin Author

    Posted 2 years ago #

    The first question is "have enabled the cron?", if yes, disable it could be resolv your issue.

    The cron is enabled in the same screen than your indicate your token and your account name.

    Let me know if this works.

    Cheers,

    Nicolas

  3. Carlos
    Member
    Posted 2 years ago #

    Hi Nicolas - thanks for your note. To confirm - we do "not" have cron enabled as it was recommended not to enable it.

  4. hippoc
    Member
    Plugin Author

    Posted 2 years ago #

    So the first thinthe solution is to verificate yours fields name. You should have at lest one of this field (name, adresse, email, telephone). The form should be filled too. Blanck form are not send. The form should be capsule enabled too, this is visible by a capsule icon in the list of form and in the edit form page. To activate it the checkbox present in form_page>edit>advanced>capsule must be checked.

    If you are sure that your form is well formed and activated. You should to activate the debug mode in the file

    <plugin directory>/api/CapsuleCRMAPI.php

    at the line 58

    const CAPSULE_DEBUG = true;

    After to have made that, errors appears if they are importants, and log are write in the directory

    <plugin directory>/api/log

    The directory should be writable for the web server (chmod 777 if you're not sure).

    Erase all file in the log directory.

    Fill a form and validate it.

    You have 4 or 5 files in the directory, you could send the file with the name debug_date in the next post.

    Nicolas.

  5. Carlos
    Member
    Posted 2 years ago #

    hi nicolas,

    thanks very much for your support. i think I followed your instructions okay - please see this zipped file that contains those debugged files.

    http://wordpressstreet.com/capsulecrm-log.zip

    please advise and thanks again.

    carlos

  6. hippoc
    Member
    Plugin Author

    Posted 2 years ago #

    For me this works and the person is created at this address:
    https://#######.capsulecrm.com/api/person/23260759

    where #### is your login, to be sure that i see the same as you i can say that is one or more characters and a number less than 6.

    Verificate with attention this URL, because, all responses are OK, like i explain in the PS.

    So i just think that you should test the address mentionned above and all will works.

    :)

    Let me know the result.

    Nicolas

    PS :

    For me and the capsule responses are clear, The person doesn't exist, you create a person {"firstName":"Test3","lastName":"Test3Last","organisationName":"Test3Company"}

    the response is ok

    after you create an address {"person":{"contacts":{"address":{"city":"Test3City","state":"MO","zip":"63129","country":"United States","street":"1253 Test3 Street"}}}

    the response is ok too

    a mail {"person":{"contacts":{"address":{"city":"Test3City","state":"MO","zip":"63129","country":"United States","street":"1253 Test3 Street"}}}

    The response is ok

    A number {"person":{"contacts":{"address":{"city":"Test3City","state":"MO","zip":"63129","country":"United States","street":"1253 Test3 Street"}}}

    Ok

    And nothing else.

    So capsule save the new person and his contacts data.

  7. Carlos
    Member
    Posted 2 years ago #

    hi there - how embarrassing. I was in capsulecrm expecting to see a notification or the latest entry show up on the latest updates/dashboard.

    so yes when I go to people - I do see the entries ;) thanks for your support. lessons learned believe me ;)

    Carlos

  8. hippoc
    Member
    Plugin Author

    Posted 2 years ago #

    Oh, i think, this is normal to take time to learn a new system.

    Happy to know that this works for you.

    I close the case,

    Ciao,

    Nico

    PS: If you have others questions, i will be here :)

  9. Carlos
    Member
    Posted 2 years ago #

    thanks again ;)

  10. EasyWaste
    Member
    Posted 2 years ago #

    Hi,

    I seem to have a similar issue to what Carlos had but am unable to sort it out using the above methods.

    Capsule is enabled, form uses the name field from Gravitys Advanced fields list, CRON disabled, green ticks on other CRM account boxes.

    The log files are in a zip here

    Any assistance you could provide would be great.

    Cheers
    Simon

  11. hippoc
    Member
    Plugin Author

    Posted 2 years ago #

    Another post created.

  12. cmykrgbb
    Member
    Posted 1 year ago #

    Hi there,

    First of all, thank you so much for creating this plugin for people with no programing abilities at all like me. Very useful.

    I am having a problem where everything seems ok, except I am not getting any new data created on capsule.

    PHP is 5.3, curl enabled, and forms are capsule enabled (Options>Advanced). So everything seems to be OK and working , but no new profiles are created in my CapsuleCRM account at all.

    I think the problem might be with the field labeling. Some fields are in Spanish, although the Admin Labels are all set in English, so that capsule can recognize them.

    You can find the log files here.

    Thanks in advance!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic