WordPress.org

Ready to get started?Download WordPress

Forums

Grand Flagallery - Photo Gallery Plugin
[Plugin: GRAND FlAGallery - Best Photo Gallery] No popups (4 posts)

  1. solkyoshiro
    Member
    Posted 2 years ago #

    Recently I've discovered that none of my galleries will expand when clicked. I'm not sure when this started but I suspect it was after the latest patch.

    I've refreshed skins, reset settings, uninstalled and reinstalled and I've even rolled back to the previous version.

    None of that has worked. The gallery populates and shows thumbnails but won't expand into the full deal.

    http://wordpress.org/extend/plugins/flash-album-gallery/

  2. solkyoshiro
    Member
    Posted 2 years ago #

    Oops forgot to link the site. http://www.epicslash.com/review/journey/

  3. Rattus
    Member
    Plugin Author

    Posted 2 years ago #

    Your theme using a lot of own scripts which already built in WordPress or other plugins. Some of javascript libraries loads twice and this gets the error (especially if loaded js libraries with different version)
    Delete script tags from your theme's header.php file
    and append to theme's functions.php file rows like this:

    <?php
    if (function_exists('load_my_scripts')) {
        function load_my_scripts() {
            if (!is_admin()) {
            wp_enqueue_script('jquery');
            wp_register_script('myscript', bloginfo('template_url').'/js/myScript.js'__FILE__), array('jquery'), '1.0', true );
            wp_enqueue_script('myscript');
            }
        }
    }
    add_action('init', 'load_my_scripts');
    ?>

    You need register and enqueue all your theme's scripts like in example above (myscript). This is right way to load scripts in WordPress.

  4. solkyoshiro
    Member
    Posted 2 years ago #

    I tried doing that and it crashed my site, hard. So unless I did something wrong (which is a possiblity given my extremely limited knowledge of php.) I don't know whats up.

    What changed that made the plugin suddenly break. Can't I just go back to a version that works with my template...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic