WordPress.org

Ready to get started?Download WordPress

Forums

GPP Slideshow
Images wont' display at full size (9 posts)

  1. donatkinson
    Member
    Posted 3 years ago #

    I want to use the fabulous gpp-slideshow plugin for a site but am unable to get the images to display at full size as in the demo despite:
    media settings - large-size: 1024
    gallery in page using single column template ( width: 900px )
    uploaded images are 900px width.

    the images that are landscape format are displaying at 640px wide.
    any portrait or square images ( max height 600px ) are displaying fine.
    I've checked everything I can think of but can't crack it.
    Any help would be much appreciated.

    http://www.donatkinson.net/sites/mike-walker/4/creative/

    http://wordpress.org/extend/plugins/gpp-slideshow/

  2. donatkinson
    Member
    Posted 3 years ago #

    The theme I'm working with is Twenty Ten 1.2.

  3. donatkinson
    Member
    Posted 3 years ago #

    OK - fixed it.
    If anyone else strikes this, its:

    functons.php
    line 47
    'if ( ! isset( $content_width ) )
    $content_width = 640;'

    Change that width and Bobs your uncle!

  4. mcboulder
    Member
    Posted 3 years ago #

    What is the path of the functions.php where you added that change? I'm looking through the code in the gpp-slideshow/gpp_functions.php location and I can't find the code you've written above for the life of me. Fantastic photos on your site by the way. Thanks!

  5. Andrei Ivan
    Member
    Posted 3 years ago #

    After trying all sorts of things to display images at 900x600 I found that the $content_width function Don mentions is in gpp-scripts.php line 84. Maybe the location is dependent by plugin version, mine is 1.0.5. Good luck!

  6. Philip Arthur Moore
    Volunteer Moderator
    Plugin Author

    Posted 3 years ago #

    Coming in a bit late on this. Base and (most of) its child themes are 620 pixels wide with a sidebar and 940 pixels wide without a sidebar. There are two ways to fix this problem. One is to edit the plugin (gpp_scripts.php):

    function gpp_gallery_slideshow_width() {
    	  global $content_width;
    		if ( ! isset( $content_width ) )
    			$content_width = 620;
    		$caption_width = $content_width - 40;
    		echo '<style type="text/css">';
    		echo '#gpp_slideshow_wrapper {width: '.$content_width.'px}';
    		echo '#gpp_slideshow .gpp_slide .caption {width: '.$caption_width.'px}';
    		echo '</style>';
    	}
    
    	add_action('wp_head', 'gpp_gallery_slideshow_width');

    Change 620 to whatever you like.

    The other, I believe, is to just define $content_width in your theme's functions.php file. That'll save you from having to tinker with the plugin files.

  7. mcboulder
    Member
    Posted 3 years ago #

    Thanks VERY much for the tips, Andrei and Phillip. No worries on the timing. Been really busy with image gathering the past few days and will try these fixes later today- let you know how I do. Much appreciated!

  8. mcboulder
    Member
    Posted 3 years ago #

    Got it working great. Here's another question: my text on the slideshow page is appearing miles down the page with a huge gap in between. How to either get the text to appear above the slideshow and/or how to shrink up that huge chunk of space? Know where to find that setting? Thanks!

  9. rickpkw
    Member
    Posted 3 years ago #

    The solution suggested above had worked for me up until yesterday, when I tried to add a new gallery, and the WordPress gallery defaults to 680 × 453

    I noticed that in the gallery dialogue the large image size is 680 × 453, even though I have set it to be 900 x 600 in the media settings.

    Does anyone have a fix for this issue?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic