WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Warning: fsockopen() [function.fsockopen]: unable to connect (5 posts)

  1. nhowarth
    Member
    Posted 6 years ago #

    I've just installed your sitemap generator plugin and I've entered by Google and Yahoo keys.

    But when I click on "Save Settings", I get two identical warning messages:

    Warning: fsockopen() [function.fsockopen]: unable to connect to 79.170.40.166:80 in /home/sites/cyprus-property-buyers.com/public_html/wp/wp-content/plugins/search-engine-verify/search-engine-verify.php on line 167

    I've had a look at the blog and the verification code has been correctly inserted. Have you any idea what's causing this?

    TIA

  2. arnee
    Member
    Posted 6 years ago #

    Hi,

    this error message comes from the search-engine-verify plugin, not from the sitemap generator plugin. I don't know it but it looks like your host doesn't allow php to connect to other websites.

  3. nhowarth
    Member
    Posted 6 years ago #

    My apologies Arnee - thanks for your reply.

  4. temporaldeideias
    Member
    Posted 6 years ago #

    I've a similar problem.

    The generator seems can't notifying Google, MSN and Ask and when I click on 'debug', I get this

    Warning: fsockopen(): unable to connect to http://www.google.com:80 in /hsphere/local/home/temporal/temporaldeideias.com/wp-includes/class-snoopy.php on line 1158 Warning: fsockopen(): unable to connect to submissions.ask.com:80 in /hsphere/local/home/temporal/temporaldeideias.com/wp-includes/class-snoopy.php on line 1158 Warning: fsockopen(): unable to connect to webmaster.live.com:80 in /hsphere/local/home/temporal/temporaldeideias.com/wp-includes/class-snoopy.php on line 1158

    What's happening?

    Thanks.

    Ricardo.

  5. Joe Banks
    Member
    Posted 5 years ago #

    Arne & temporaldeideias,

    Temporaldeideias's issue happened for us for our WP-hosting server that is behind a huge, honkin' firewall/proxy. WordPress was attempting to go outside the firewall without the proper credentials (host and port)!

    So, finally, we figured out to go into /wp-includes/class-snoopy.php and substitute these values:

    var $proxy_host = "HERE"; // proxy host to use
    var $proxy_port = "AND_HERE"; // proxy port to use

    additionally, these values, if proxy requires user/pass. Not necessary for us.

    var $proxy_user = "HERE"; // proxy user to use
    var $proxy_pass = "AND_HERE"; // proxy password to use

    After putting in the correct settings, we experienced NO MORE fsockopen errors!

Topic Closed

This topic has been closed to new replies.

About this Topic