WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
[resolved] There was a problem writing your sitemap file (7 posts)

  1. kortech
    Member
    Posted 2 years ago #

    I have configured the Google XML Sitemaps plugin to "Build the sitemap in a background process (You don't have to wait when you save a post)" and to use Automatic detection to determine the location of my sitemap file. With that configuration, whenever the plugin tries to rebuild my sitemap in the background, it fails with "There was a problem writing your sitemap file. Make sure the file exists and is writable." It works fine when I manually rebuild it.

    Because my WP site is running on an IIS server, many of the posted suggestions for resolving this problem don't apply (e.g. chmod).

    I was able to resolve this problem on my system by selecting Custom location as the location of my sitemap file. I used the exact same URL as the default, but for the file path, I replaced the / with a \, i.e. I replaced D:\webs\www.mydomain.org\wp/sitemap.xml with D:\webs\www.mydomain.org\wp\sitemap.xml.

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. roothost
    Member
    Posted 2 years ago #

    I have configured the Google XML Sitemaps plugin to "Build the sitemap in a background process (You don't have to wait when you save a post)" and to use Automatic detection to determine the location of my sitemap file. With that configuration, whenever the plugin tries to rebuild my sitemap in the background, it fails with "There was a problem writing your sitemap file. Make sure the file exists and is writable." It works fine when I manually rebuild it.

    Because my WP site is running on an IIS server, many of the posted suggestions for resolving this problem don't apply (e.g. chmod).

    I was able to resolve this problem on my system by selecting Custom location as the location of my sitemap file. I used the exact same URL as the default, but for the file path, I replaced the / with a \, i.e. I replaced D:\webs\www.mydomain.org\wp/sitemap.xml with D:\webs\www.mydomain.org\wp\sitemap.xml.

    http://wordpress.org/extend/plugins/google-sitemap-generator/

    Now that was easy! Spent ages trying to figure this out, nice find :)

  3. fwchapman
    Member
    Posted 2 years ago #

    Thank you so much! Changing the forward slash to a back slash in the custom location solved my problem as well. Removing the slash entirely also seems to solve the problem.

  4. fwchapman
    Member
    Posted 2 years ago #

    Actually, I may have spoken too soon. Changing or removing the slash gets rid of the error message, but my sitemap files are still empty.

  5. rahul301
    Member
    Posted 2 years ago #

    Please help.
    Iam also getting the same message:
    "There was a problem writing your zipped sitemap file. Make sure the file exists and is writable"

    I have tried saving at both places my laptop (C:\Users\Preity\Documents\Downloads\sitemap.xml)

    as well on website folder( after changing CMOD to 777, as well)

    It is not working for me. can you please help.

  6. fwchapman
    Member
    Posted 2 years ago #

    I was eventually able to get this plugin to work on websites with a shared hosting plan and a shared SSL certificate. I used a custom location based on the following patterns for the path and URL:

    Absolute or relative path to the sitemap file, including name.

    /home/USERnn/public_html/sitemap.xml

    Complete URL to the sitemap file, including name.

    http://SERVERnnn.MY_HOSTING_COMPANY.com/~USERnn/sitemap.xml

    I temporarily installed the Better WordPress Google XML Sitemaps plugin, which does a better job of figuring out the location, and then uninstalled it once I got the location.

    Here's what I use in Settings > General on websites with shared hosting and a shared SSL certificate:

    WordPress Address (URL)

    https://SERVERnnn.MY_HOSTING_COMPANY.com/~USERnn

    Site Address (URL)

    http://www.MY_SITE.com

    I hope this helps!

    Fred

  7. fwchapman
    Member
    Posted 2 years ago #

    P.S. Here's a more generic form for the first item:

    Absolute or relative path to the sitemap file, including name.

    /HOME_DIRECTORY/USERNAME/public_html/sitemap.xml

    I've found that some hosting companies use numbers in the name of the home directory and some don't. The same thing applies to the username.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic