WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] "There was a problem writing your sitemap file" (8 posts)

  1. jdorenbush
    Member
    Posted 4 years ago #

    I am receiving the following two error messages when trying to generate my site map:
    "- There was a problem writing your sitemap file. Make sure the file exists and is writable."
    "- There was a problem writing your zipped sitemap file. Make sure the file exists and is writable."

    I have a custom location set to where the sitemap is at, and have double checked to confirm it is in the place I have listed, and it is.

    I have both "sitemap.xml" and "sitemap.xml.gz". The permissions for these files are "rwx r-x r-x".

  2. jdorenbush
    Member
    Posted 4 years ago #

    Anyone?

  3. jdorenbush
    Member
    Posted 4 years ago #

    A complete uninstall and re-creation of files seemed to have fixed it. Still unsure of the root of the problem, but oh well.

  4. panan
    Member
    Posted 4 years ago #

    You can do this:
    When you come to this section, some of the blogger will found difficulties to create the sitemap, you require to create a “sitemap.xml” file and “sitemap.xml.gz” file and upload it into the public_html directory.

    How to create sitemap.xml and sitemap.xml.gz ?

    If you do not know how to create “sitemap.xml” file and “sitemap.xml.gz”, simply open a notepad, save file as “sitemap.xml” and another one save file as “sitemap.xml.gz“

    Upload it to ur webhosting public_html directory, you definitely found the same issue,

    There was a problem writing your sitemap file. Make sure the file exists and is writable

    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable

    The sitemap.xml and sitemap.xml.gz are not writable yet, to change the ftp file permission to become writable, click on the file, and edit the CHMOD. it require to be writable on this 2 file. You need to change the this the FTP file permission to become writable, or “777″.
    Once done, both file are writable. You can update the option or rebuild sitemap manually
    cheers.
    Panan

  5. Dod
    Member
    Posted 4 years ago #

    I found 2 methods to get round this:

    1. Create 2 empty files named sitemap.xml and sitemap.xml.gz upload to your blog directory and CHMOD to 666. Then generate your sitemap

    or

    2. Temporarily CHMOD your blog directory to 777 to allow the plugin to write the files the 1st time. Then, once the sitemap files are created, CHMOD your blog directory back to 755 or whatever it was before.

    Cheers
    Dod

  6. barbosay
    Member
    Posted 4 years ago #

    I have the same problem for months in 1 site, I already contact the Plugin Designer, chek tons of forums, nothing works :(

  7. Mike
    Member
    Posted 4 years ago #

    i tried uninstalling it and then reinstalling it and when i did this and went to build it again the first time it was already built!!!

    is this a database problem?

    nothing has worked. all permissions are correct, and uninstalling and reinstalling did nothing

  8. Ulfsby Webdesign
    Member
    Posted 4 years ago #

    I had the same problem. It was the service provider of my host that had set the owner of the root directory to be nobody, making it unwriteable for WordPress. I came around it by configuring the plugin to write the sitemap on a subdirectory and put the following text in the file robots.txt on the root:

    User-agent: *
    Sitemap: http://ulfsby.no/webdesign/sitemap.xml.gz

    This will allow all search robots to search and to find the sitemap.
    It solved the problem, Google found the sitemap.

    Visit my free WordPress themes

Topic Closed

This topic has been closed to new replies.

About this Topic