WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] The sitemap files could not be written! (6 posts)

  1. Dennis D
    Member
    Posted 6 years ago #

    Hi,

    I just installed the beta version, and I am still receiving the same error. I changed the CMOD of the two files, and still no luck.

    Appreciate any suggestions. Or a suggestion of a different plugin.

    Thanks,

    Dennis

  2. Michael Torbert
    WordPress Virtuoso
    Posted 6 years ago #

    Did you check to make sure they're in the path specified in the options page?
    What did you chmod them to?
    You can always try temporarily chmoding the directory itself to give write access and have the plugin generate the files.

  3. Dennis D
    Member
    Posted 6 years ago #

    I'm not sure about the path. I can't seem to find the "options" page you mentioned. Where would I start looking for it?

    Thanks,

    Dennis

  4. Dennis D
    Member
    Posted 6 years ago #

    I put the two files in various places, and then made the root 777.
    I received the following error:

    Forbidden

    You don't have permission to access /wp-admin/options-general.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.8g DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.themysterystartshere.com Port 80

    Now I'm really confused.

    Can anyone help?

  5. Michael Torbert
    WordPress Virtuoso
    Posted 6 years ago #

    First, the options page is under admin->settings->xml-sitemap. Down at the bottom, you'll see a path, either put your sitemap there or move your sitemap to that path. Either way, they need to match up so that the plugin knows where to find your sitemap.
    You said you changed the permissions of each file, and that you just placed them somewhere. You need to be more specific. What did you chmod them to? Where exactly did you put them? Why did you make the root of your WordPress installation 777? That's very bad, unless you meant temporarily while trying to set up these files.
    You said that you get this error message:

    You don't have permission to access /wp-admin/options-general.php on this server.

    What exactly are you doing when you get it? Is it when you "update" the options in the xml-sitemap plugin and try and have it modify the files? or are you doing something else when this happens?

  6. Dennis D
    Member
    Posted 6 years ago #

    Hi,

    Thank you for your help. I followed your instructions and found the options. I also found the "Location of your sitemap file" block. It showed both an automatic detection with two paths and a custom location with two paths.

    The custom location, showed /home/themyst8/public_html/sitemap/sitemap.xml.

    I checked with cPanel file manager and I had:
    /home/themyst8/public-html/sitemap.xml

    So I created an empty folder called sitemap in public_html, and moved the two sitemaps to it. Did a rebuild and it WORKED.

    Fantastic. I still don't fully understand why it worked - but I'm glad that it did.

    Thanks again.

    Dennis

Topic Closed

This topic has been closed to new replies.

About this Topic