WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] The last run didn't finish! Maybe you can raise the memory or time lim (18 posts)

  1. spatel6549
    Member
    Posted 5 years ago #

    I get an error message when trying to build my sitemap. Here is the error in detail:

    # he last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts.
    # The last known memory usage of the script was 14.75MB, the limit of your server is 64M.
    # The last known execution time of the script was 26.57 seconds, the limit of your server is 120 seconds.

    After some research, I updated my php.ini as follows:

    max_execution_time = 600 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    ;memory_limit = 128M ; Maximum amount of memory a script may consume (8MB)
    memory_limit = 512M ; Maximum amount of memory a script may consume (8MB)

    What am I doing wrong?

  2. jeffimperial
    Member
    Posted 5 years ago #

    I'm having the same problem here. The message is either one of the following:

    **********************************
    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 10.75MB, the limit of your server is 32M.
    # The last known execution time of the script was 4.9 seconds, the limit of your server is 10 seconds.
    # The script stopped around post number 85 (+/- 100)
    **********************************
    ----------OR------------
    **********************************
    * The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    * If you changed something on your server or blog, you should rebuild the sitemap manually.
    * If you encounter any problems with the build process you can use the debug function to get more information.
    **********************************

    And yes, I have tried changing maximum memory and processing time caps; none worked. I have also come to edit the php.ini file, all to no avail.

    At first, it was working just fine. Now, this. Any ideas?

  3. dennislv
    Member
    Posted 5 years ago #

    I'm having the same problems:

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 29.75MB, the limit of your server is 90M.
    # The last known execution time of the script was 45.81 seconds, the limit of your server is 120 seconds.
    # The script stopped around post number 12018 (+/- 100)

  4. sorinv
    Member
    Posted 5 years ago #

    The same problem here:

    # The last run didn't finish! Maybe you can raise the memory or time limit
    for PHP scripts. Learn more
    # The last known memory usage of the script was 15.75MB, the limit of your
    server is 64M.
    # The last known execution time of the script was 0.6 seconds, the limit of
    your server is 120 seconds.
    # The script stopped around post number 908 (+/- 100)

    and in debug file is something like this:

    Errors, Warnings, Notices

    Notice: Undefined index: debug in
    /home/business/public_html/wp-content/db.php on line 645

    Notice: Undefined index: debug in
    /home/business/public_html/wp-content/db.php on line 646

    some help will be great

  5. sorinv
    Member
    Posted 5 years ago #

    i receive this error when i want to include in the sitemap the tag pages

  6. liannef
    Member
    Posted 5 years ago #

    Same error here...Mine is

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 14.24MB, the limit of your server is 40M.
    # The last known execution time of the script was 0.33 seconds, the limit of your server is 50000 seconds.
    # The script stopped around post number 302 (+/- 100)

    What is going on?? Anyone know anything?

  7. jalanbk
    Member
    Posted 5 years ago #

    I was also getting same error, and after few hit nad try I found that It Global translator plugin which is creating problem for Sitemap...

    If I disable translator sitemap works fine , Try this - it may work for you as well..

  8. cite
    Member
    Posted 5 years ago #

    We're experiencing the same problem, the site were dealing with has approx 22,700 posts & its timing out. When we disable the archives setting it still appears to be including them; we're not clear on the definition of 'archive' as to our understanding it means anything not in the current month, hovever these is an option to include the 'archive of the current month' which makes no sense. We've reduced the number of posts to include '10,000' & increased the memory usage limit to 32M.

    Any help greatly appreciated.
    Thanks.

  9. kirk34
    Member
    Posted 5 years ago #

    Did anyone figured this out yet, Im getting the same results as everyone else thats posted?

  10. kirk34
    Member
    Posted 5 years ago #

    Error Im getting, anyone, anyone...?

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 18.5MB, the limit of your server is 64M.
    # The last known execution time of the script was 2.64 seconds, the limit of your server is 3000 seconds.
    # The script stopped around post number 3182 (+/- 100)

  11. jalanbk
    Member
    Posted 5 years ago #

    try disbaling your other plugins one by one...

    I am sure it works...

    It is something like plugins are getting cross linked...
    As I have experienced this on many site and on each site disabling some plugin or other works and then if you enable that plugin, everything works fine

  12. duncan
    Member
    Posted 5 years ago #

    I've been tackling this problem for two days. Tried the MySQL standard mode option suggested elsewhere, it worked once, then never again.

    In the end I tried what was suggested above: remove the tag pages...and so far it's magically working again.

    Not sure why the problem is related to tags, but if you're stuck like I was, try unticking the include tag option.

  13. macke
    Member
    Posted 4 years ago #

    Problem is in global translator, uncheck Enable sitemap integration, and xml sitemap generator will work.

    macke92@gmail.com

  14. arnee
    Member
    Posted 4 years ago #

    Hi,

    the plugin itself doesn't use so much memory if the MySQL Standard mode is NOT checked. Enabling the standard mode uses more memory and should be only activated if you get MySQL errors from other plugins during the build process.

    The main cause of high memory usage are often plugins which hook in the functions for generating the permalinks and performing additional mysql queries there.

  15. Omega407
    Member
    Posted 4 years ago #

    Had the same problem, try to untick ask.com in the plugin settings, and the rebuild the sitemap. It worked for me.

  16. Pino262
    Member
    Posted 4 years ago #

    I SOLVEd THE PROBLEM AFTER 2 DAYS SEARCHING! My problem was a wrong sitemap integration from Global Translater Plugin and XML-Sitemap Plugin:

    If this aint your problem try increasing your memory or learn .htacces
    If it is look, down here now.

    GO TO YOURSITE.COM/wp-admin/options-general.php?page=global-translator/options-translator.php

    Now scroll a bit down and uncheck this: Enable sitemap integration

    Also some1 at my school found this sql injection attack wich is availbe when both plugins are activated. here it is

    /wp/index.php?cat=%2527+UNION+SELECT+CONCAT(666,CHAR(58),user_pass,CHAR(58),
    666,CHAR(58))+FROM+wp_users+where+id=1/*
  17. jreither
    Member
    Posted 4 years ago #

    I had a similar issue, and found out it was caused by a conflict with another translate plug-in called Ultimate Translate (for WordPress MU). I deactivated the Translate plug-in and the XML Sitemap plug-in worked once again.

    I've posted a question on the developer forum of the translate plug-in to see if they have any info on this and other issues I was having with that plug-in.

  18. Pino262
    Member
    Posted 4 years ago #

    or put this in your htacces
    php_value memory_limit 256M
    php_value max_execution_time 720
    php_value max_input_time 60

    heres a part of my htacces file.... might help some people

    <files .htaccess>
    order allow,deny
    deny from all
    </files>
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    php_value memory_limit 256M
    php_value max_execution_time 720
    ServerSignature Off
    # limit file uploads to 10mb
    LimitRequestBody 10240000
    # limit file uploads to 10mb
    # disable directory browsing
    Options All -Indexes
    # disable directory browsing
    # protect from spam comments
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*piratebayz.org.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]
    # protect from spam comments

Topic Closed

This topic has been closed to new replies.

About this Topic