WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
[resolved] # Symbol added as a link in my sitemap (10 posts)

  1. Smith
    Member
    Posted 2 years ago #

    I created my sitemap the way I normally do for other WordPres sites, but for some reason this sitemap has added a # symbol as a link listed in my sitemap. This # link is causing Google Webmaster Tools to reject the sitemap. I have a few pages on my site that redirect to # links, but all of those pages have been added to the exclude list in the plugin.

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. csogilvie
    Member
    Posted 2 years ago #

    I'm also suffering from this issue on a site.

    The only thing I can think that's different between this and other sites is the fact that this site is using Suffusion as a theme, and also has some top-level pages which are not linked to in the site.

  3. gointothewild
    Member
    Posted 2 years ago #

    I have this same issue as well. With the # in the loc XML element, Google Webmaster Tools will not accept the site map. Has there been any resolution to this issue?

  4. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    what do you mean exactly with "top-level pages which are not linked to in the site"?

    Does this problem still exists in the latest beta?

  5. gointothewild
    Member
    Posted 2 years ago #

    Yes, this problem exists in the latest beta. Thanks.

  6. gointothewild
    Member
    Posted 2 years ago #

    Just discovered that the problem goes away when I deactivate the "Page Links To" plugin. Not sure if csogilvie is using this plugin but there is a definite conflict.

  7. Karesansui
    Member
    Posted 2 years ago #

    I also have this problem.
    The Weaver theme gives an option to "switch off" a page to appear in the menu, and to become a dead-page (dead main menu option) where only underlying pages are active in the dropdown menu.

    This is from the theme support forum:

    For a page checked as: Menu "Placeholder" page in the Theme (great feature that I need), the sitemap has an entry with only: #
    And that is regarded invalid sitemap-syntax.

    Is there anything I can do in the Theme or page or would this be a sitemap-generator bug ?

    It is fairly standard to use a link with simply '#' to mean "here". I would think the sitemap-generator should know about that common idiom. There's a simple JavaScript equivalent that some HTML writers use instead (don't remember right off the top of my head) that should be handled as well.

    To temporarily solve this I switch the theme-option off again but for sure I would like to use that feature.

    Thanks, Piet

  8. Evert
    Member
    Posted 2 years ago #

    Experiencing the same issue, for example here: http://donateaday.net/sitemap-pt-page-2011-01.xml

    Using the Suffusion theme.

  9. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

  10. Evert
    Member
    Posted 2 years ago #

    It is indeed! :-)

    (PS: Don't forget to update http://www.arnebrachhold.de/projects/wordpress-plugins/google-xml-sitemaps-generator/ . It still says 4.0b6 Beta is most recent beta)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic