WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Suddenly getting errors when building Sitemap (16 posts)

  1. manunkind
    Member
    Posted 6 years ago #

    Hello,

    All of a sudden, I now noticed that my sitemap is not building and it states the following:

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 13.49MB, the limit of your server is 40M.
    # The last known execution time of the script was 0.46 seconds, the limit of your server is 50000 seconds.
    # The script stopped around post number 394 (+/- 100)

    When I manually try to build it, it just displays a blank page and when I return to the main page it just gives me the above errors. I am nowhere close to my server limits as stated above. This seemed to just start happening for no reason.

    Any ideas?

  2. arnee
    Member
    Posted 6 years ago #

    Hi,

    could you click on the "debug function" link and have a look at the "Errors, Warnings, Notices" section?

    Best regards,

    Arne

  3. manunkind
    Member
    Posted 6 years ago #

    It's empty. I already checked that before posting.

    And another update, it's seems to be getting worse. I was able to get it to run when I limited the posts to about 300. Now, it's failing at 100 posts. Makes no sense.

  4. manunkind
    Member
    Posted 6 years ago #

    Can someone zip up the previous version of this and send it to me? I want to see if maybe it's just this latest version that was released on 3/3/08.

  5. Rok
    Member
    Posted 6 years ago #

    Can someone zip up the previous version

    It won't make any affect. As I'm also experiencing the same problem, right after upgrading to WordPress 2.5. Earlier on WordPress 2.3.3, I was able to generate sitemap with just one click and withing 15-35 sec.

  6. rdkr
    Member
    Posted 6 years ago #

    I had trouble also. When I added a site map to google webmaster tools it was getting a 303 error code. I had noticed a drop in site traffic since up-grading to 2.5 but since I turned off the sitemap and and deleted to site map files (xml/gz), my site traffic is on the increase again.

  7. manunkind
    Member
    Posted 6 years ago #

    Ok, well I guess I'm not alone. Is there another Sitemap plugin that actually works with 2.5. This one was great, but completely useless to me now.

  8. ThorHammer
    Member
    Posted 6 years ago #

    I chmoded the sitemap.xml and the zippd sitemap to 766, then it worked.

  9. Geetar
    Member
    Posted 6 years ago #

    This plugin works fine, unfortunately it uses a lot of resources. Try to increase your memory via php.ini or tick "Build the sitemap in a background process".

  10. manunkind
    Member
    Posted 6 years ago #

    ThorHammer wins. Changing the permissions on the two output files makes it work correctly again. Thank you.

  11. Rok
    Member
    Posted 6 years ago #

    Permissions are correct & "Build the sitemap in a background process" is ticked. Eventhough, it doesn't work in WordPress 2.5

    Earlier in WordPress 2.3.3, I was able to generate sitemap with just one click under 5-15 seconds. Now after upgrading, I only gets "last run didn't finish" error.

    @rdkr

    Where you turned off and deleted sitemap files in "WordPress" or "Google Webmaster Tools"?

  12. rdkr
    Member
    Posted 6 years ago #

    Rok
    I deleted both of them.

    "

    Permissions are correct & "Build the sitemap in a background process" is ticked. Eventhough, it doesn't work in WordPress 2.5

    Earlier in WordPress 2.3.3, I was able to generate sitemap with just one click under 5-15 seconds. Now after upgrading, I only gets "last run didn't finish" error.

    @rdkr

    Where you turned off and deleted sitemap files in "WordPress" or "Google Webmaster Tools"?
    "

  13. AJKock
    Member
    Posted 6 years ago #

    I get the following notice:
    Notice: Undefined index: path in /home/ajkcoza/public_html/wp-admin/includes/file.php on line 25

  14. arnee
    Member
    Posted 6 years ago #

    Hi all,

    thanks for the feedback! There was a change in the WordPress 2.5 caching system which resulted in a database query for every post when the sitemap was created. Because of this, it is likely that the script run into the memory or time limit.

    I've added a workaround in the new 3.0.3.2 release which fixes this issue. You can get it here:

    http://downloads.wordpress.org/plugin/google-sitemap-generator.3.0.3.2.zip

    I'm also working on the new major version of the plugin which is split into several files, so only the PHP code which is needed for the current request is loaded. That means that only a very small "code loader" is active on every page load and the sitemap generator itself is just loaded when you really want to rebuild the sitemap.

    You can help me by testing the new test release (also known as "development version"). Note that this version might not work completly, but it would be great if you help me and report what's not working :)

    The current development version is always here:
    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

    Please note that if you update to this version, the plugin should be automatically disabled afterwards since the filename of the core plugin file changed. You'll need to activate it again at the plugin page.

    Thanks and best regards,

    Arne

  15. peeds
    Member
    Posted 6 years ago #

    Hi,

    I have tried 3.0.3.2 and 3.0.3.3, and I see this error with WordPress 2.5.1:
    "Notice: Undefined index: path in /blog/wp-admin/includes/file.php on line 25"

    My blog is hosted on Yahoo.

    Thanks in advance.
    -peeds

  16. gusleig
    Member
    Posted 6 years ago #

    This plugin is making my server CPU skyhigh since I ugraded for wp 2.5.

    Im looking for an option for generating my sitemaps manually.

Topic Closed

This topic has been closed to new replies.

About this Topic