WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Script loops when building site map for first time (9 posts)

  1. esmi
    Forum Moderator
    Posted 5 years ago #

    When building the site map manually for the first time, the script continually loops and can only be halted via the browser. The sitemap appears to be generated without any problem and subsequent manual rebuilds are problem free. It's just the first time that the looping occurs. I've now had this happen on 3 different WP installs. All 2.8 using XML Sitemap 3.1.3. The only common active plugins were Akismet and Quicktag Extender.

  2. Jeff Fohl
    Member
    Posted 5 years ago #

    This happened to me as well. Also using WP 2.8.

  3. derehtcire
    Member
    Posted 5 years ago #

    This happened to me today, using WP 2.7.

  4. zamba
    Member
    Posted 5 years ago #

    Yep, I've had this happen on 2.8 and 2.7 today as I installed it on several blogs. Once it did not loop and gave me the correct report page immediately, but I couldn't work out what was different on this installation (all use same plug-ins).

    On return to the settings page the report is there.

    Tony Page

  5. forbairt
    Member
    Posted 4 years ago #

    Hi Guys,

    Looks to me like its the first time you try to manually generate the sitemap.xml sitemap.xml.gz

    Clicking away from the page and going back shows me (at least) that they were unwritable ... both didn't exist so I had to create the two and set 775 permissions on them (or 777) ...

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    I don't think it's a permissions issue as the files were successfully created every time on my servers. The previous version of the plugin appeared to hang after the file was created. The most recent version shows all the signs of running through an infinite loop - even though, again, the sitemap file was successfully created immediately.

  7. metapede
    Member
    Posted 4 years ago #

    I just posted about this:

    http://wordpress.org/support/topic/295151?replies=1

    I'm having the same issue; I searched but somehow missed this existing thread. I'll update the other thread to point to this one.

  8. berisberis
    Member
    Posted 4 years ago #

    the same happened to me... now i have this message:

    # There was a problem writing your sitemap file. Make sure the file exists and is writable. Learn more
    # There was a problem writing your zipped sitemap file. Make sure the file exists and is writable. Learn more

    I already created the sitemap.xml and sitemap.xml.gz files, upload them via FTP to my server and changed permissions on filezilla FTP client to 755.

    it keeps displaying the error... help!

  9. berisberis
    Member
    Posted 4 years ago #

    i already deactivated all plugins to see if there was a conflict.. but same result.

Topic Closed

This topic has been closed to new replies.

About this Topic