WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Problem writing sitemap file (6 posts)

  1. Tim F
    Member
    Posted 5 years ago #

    When first generating the sitemap after installing the Google XML sitemaps plugin, the screen stayed white for a very long time until I had to restart. Now, when clicking the manual rebuild link, I get the message 'There was a problem writing your sitemap file. Make sure the file exists and is writable'.

    I have followed the steps in the faq and deleted the original sitemap.xml and sitemap.xml.gz files and replaced them with empty text files saved with those names, and changed the permissions as per the FAQ. However I'm still getting the message. Any thoughts on my next step?

    Cheers,
    Tim

  2. skytez
    Member
    Posted 5 years ago #

    When first generating the sitemap after installing the Google XML sitemaps plugin, the screen stayed white for a very long time until I had to restart. Now, when clicking the manual rebuild link, I get the message 'There was a problem writing your sitemap file. Make sure the file exists and is writable'.

    I have the same problem exactly. And I followed the FAQ to resolve.
    What to do?
    Thanks
    Terry

  3. Pranav Rastogi
    Member
    Posted 5 years ago #

    CHMOD public_html folder to 777 and generate sitemap. After that, give back the permissions public_html folder had before.

  4. Tim F
    Member
    Posted 4 years ago #

    hostgator hosting doesn't allow users to set permissions to 777. I've resolved this issue by just using a different plugin but would love to hear any othre workarounds!

  5. subhashsrs
    Member
    Posted 4 years ago #

    There was a problem writing your sitemap file. Make sure the file exists and is writable. Learn more
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable. Learn more
    The problem persista....I have find n solution

  6. Rezaei12
    Member
    Posted 4 years ago #

    I'm also experiencing the same problem

Topic Closed

This topic has been closed to new replies.

About this Topic