WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
Numerical entries in sitemap that lead to 404's (11 posts)

  1. Graham Stoney
    Member
    Posted 3 years ago #

    My XML sitemap contains a bunch of entries which end in numbers, creating URLs that don't exist on my site. For example, see http://confidentman.net/sitemap.xml

    Has anyone else noticed this problem?

    Thanks, Graham

  2. crowly
    Member
    Posted 3 years ago #

    Hi Graham, I am having the same problem. Lots of urls ending in numbers that DO NOT exist. Hope they fixed that soon.

  3. webjunk
    Member
    Posted 3 years ago #

    @Graham Stoney
    ALl the link in your sitemap (even ending in a number) seem to be valid posts and pages.

  4. crowly
    Member
    Posted 3 years ago #

    Hi Graham , just want to share it you that if you use the gz version there will be no additional non existing url.

  5. crowly
    Member
    Posted 3 years ago #

    Hi Webjunk, trust me the plugin is adding non existing urls.

  6. Graham Stoney
    Member
    Posted 3 years ago #

    The problem seems to be intermittent; it comes and goes... I've seen it a couple of times before, but never been able to pin it down. Crowly, do you have a live site which is currently affected? Thanks, Graham

  7. Graham Stoney
    Member
    Posted 3 years ago #

    Manually rebuilding the sitemap sometimes gets rid of the bad entries, but I'm pretty sure I've seen them generated in manual builds too.

    @crowly: It makes no difference whether it's the .gz version or not.

    @webjunk: There are no articles on my site ending in a number. All such links are invalid when they appear and give 404's when accessed unless Smart404 happens to spot a match in part of the URL.

  8. crowly
    Member
    Posted 3 years ago #

    Hi Graham, when I stopped building the xml version at all due to the non existing url. In the .gz version everything is fine for me.

  9. crowly
    Member
    Posted 3 years ago #

    Now Google is having problems with the sitemaps lol

  10. crowly
    Member
    Posted 3 years ago #

    I am now having problems with the .gz as well...

  11. crowly
    Member
    Posted 3 years ago #

    Anyone have a remedy for this ?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic