WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Not indexing static page? (16 posts)

  1. Alkorr
    Member
    Posted 5 years ago #

    Hi, I just realized my static pages are ignored by the plugin, is it normal? Because my blog has many static pages so if the sitemap doesn't include them, then Google won't index them and the sitemap is no use at all...

    Any idea? Thanks!

  2. hazematic
    Member
    Posted 5 years ago #

    Hi! I got the same problem here with wp 2.8.4. Had no problem on a local installation with wp 2.6, but after installing it on the web server - no static pages anymore.

    I tried to disable all plugins and turned off the permalinks, but this didn't help.

    As a workaround I have added all my static pages manually, but of course this is not the solution...

    Anybody any hint? Thank you.

  3. Lee Willis
    Member
    Posted 5 years ago #

    Hi, I just realized my static pages are ignored by the plugin, is it normal?

    Have you got "Include static pages" selected in the plugin options?

    Because my blog has many static pages so if the sitemap doesn't include them, then Google won't index them and the sitemap is no use at all...

    Google will still index your pages as long as they are linked somewhere on your site. Just because they don't appear in your XML sitemap doesn't mean they're invisible.

  4. Alkorr
    Member
    Posted 4 years ago #

    Hi leewillis, of course I selected "Include static pages" in the plugin options.

    And of course Google will still index my pages but the purpose of this plugin is to optimize referencing. Since my blog is only static pages, I had to create an XML sitemap by myself and not use this great plugin... Pity.

  5. Alkorr
    Member
    Posted 4 years ago #

    3.1.5 is out, but apparently it still doesn't include static pages into the sitemap... That's so bad, this plugin is so great :(

    But I'm still thinking maybe I am the only one (and hazematic) with this problem...

  6. arnee
    Member
    Posted 4 years ago #

    Hi,

    sorry, but I can't reproduce this bug. If anybody of you could contact me by mail so I can have a look directly at your blog to find out whats wrong? Thanks! arne at arnebrachhold dot de

    - Arne

  7. mberkom
    Member
    Posted 4 years ago #

    I'm having the same problem with wp 2.8.4 and the latest version of XML-Sitemap Generator. The only pages that are showing up are post pages!

  8. juust
    Member
    Posted 4 years ago #

    I had the same problem. Pages are standard marked 'uncategorized'. That category was marked for exclusion in the sitemap build, once I included 'uncategorized' in the build it included all the pages.

  9. mberkom
    Member
    Posted 4 years ago #

    Great answer. That fixed my problem.

    Thanks!

  10. doggettfitness
    Member
    Posted 4 years ago #

    Thank you, 'juust'. I was experiencing the same difficulty and your helpful post solved the problem.

  11. Newzic
    Member
    Posted 4 years ago #

    Same probleme with statics pages not include un sitemap.xml. I search a long time and I found that:
    defaut category for post (for unclassed posts) must not be check.
    In french : ne pas cocher "Catégories exlues > Non classé".

    See also this post.

  12. fullvalue
    Member
    Posted 4 years ago #

    I deleted the uncategorized category. What can I do now to get my static pages to show up on the map? What is interesting is that the sitemap.xml.gz shows all the pages but not sitemap.xml. Thoughts?

  13. fullvalue
    Member
    Posted 4 years ago #

    Never mind...I realize it was a cache issue. Plugin works great!

  14. arnee
    Member
    Posted 4 years ago #

    Hi,

    thanks for this hint. Since pages don't have a category, I will remove the exclusion check for pages in the next release.

    Thanks for pointing this out!

    Best regards,

    Arne

  15. roshanratnayake
    Member
    Posted 4 years ago #

    i have the same problem, google is not indexing

    http://roshanratnayake.wordpress.com/

  16. pixel8r
    Member
    Posted 4 years ago #

    Just to confirm, the tip by juust about removing the uncategorized exclusion worked for us. Static pages were included in the sitemap after unchecking uncategorized in the Excluded categories list of the plugin options page.

    Thanks for the tip.

Topic Closed

This topic has been closed to new replies.

About this Topic