WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
Manual build works, automatic fails permissions (10 posts)

  1. spikeyuk
    Member
    Posted 3 years ago #

    I have WordPress hosted on a Windows server. I created the two sitemap files manually and set full permissions on each. If I rebuild my sitemap manually (from the Rebuild option) it is fine, if however I change some content, when I go to the sitemap config page I have errors saying it couldn't write to the files (and the sitemaps are NOT updated)....

    Can anyone help me?!

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. MrFantsyPants
    Member
    Posted 3 years ago #

    I've got the exact same situation happening. Windows server, manual updates work, automatic generation fails. Looking into it.

  3. spikeyuk
    Member
    Posted 3 years ago #

    Did you have any luck with this?

  4. poddys
    Member
    Posted 3 years ago #

    My automatic build says that it worked, but the sitemaps are showing the old date, which can be several months old, despite the sitemap being rebuilt daily.

    If I rebuild manually that does work ok.

  5. poddys
    Member
    Posted 3 years ago #

    I may have the answer for this...

    I just found an updated Sitemap in my top folder for my hosting account, not in the correct folder for the domain.

    My hosting structure is as follows:

    main account
    --> .htaccess is here
    htdocs
    --> automatic sitemaps.xml found here
    domain1
    htdocs
    --> manually created sitemaps.xml found here
    domain2
    htdocs

    The manually created sitemaps.xml is created where it is supposed to be, and where Google expects it to be.

    This may indeed be the problem, and related to a problem I have experienced with several other plugins as well.

    A .htaccess file at the top level redirects to the correct domain.

  6. ELMIT
    Member
    Posted 3 years ago #

    I have a MU blog site of the type subdirectory:

    http://blog.com/blog-1
    http://blog.com/blog-2
    ...

    The domain blog.com is linked to the directory /home/me/wordpress
    The sitemap directory is /home/me/wordpress/sitemaps

    Manually, all sitemaps are updated, automatically I get the above errors:

    There was a problem writing your sitemap file. Make sure the file exists and is writable.
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable.

    I changed the permission already of the files to 755, but still the same.

    I could not find any other sitemap files on my system.

    Any ideas?

    bye

    Ronald

  7. thegunninghawk
    Member
    Posted 3 years ago #

    I am having the same, exact problem.

    Manual works, automatic failed. Clearly, the automatic system is trying to write the files in another directory, but which one, and why?

  8. ELMIT
    Member
    Posted 3 years ago #

    I found the solution (thought I posted it here, must have done on another place):

    Just change "Automatic detection" to "Custom Location"
    Both include the same path, but with the Custom Location it works then also automatically.

    It seems to me, that automatic detection does not use the full path in the program, but relative, so when you call it manual, you are at the right place to start with, ...

    Please report if that worked for you too.

  9. thegunninghawk
    Member
    Posted 3 years ago #

    I think it did, thanks!

  10. twofourseven
    Member
    Posted 3 years ago #

    Apologies for the question - I'm not a coder.

    I have just installed the 'Google Sitemap Generator' plugin on my site and set the CHMOD to 666. I have then gone to 'XML-Sitemaps' to build the first sitemap but get the following error message: "You do not have sufficient permissions to access this page."

    What do I need to do?

    Help appreciated!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic