WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Fatal Error while rebuilding (10 posts)

  1. Fawked
    Member
    Posted 6 years ago #

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 30720 bytes) in /home/fawked/domains/fawked.net/public_html/wp-includes/class-snoopy.php on line 167

    How can I fix that?

  2. Fawked
    Member
    Posted 6 years ago #

    Anybody?

  3. arnee
    Member
    Posted 6 years ago #

    Please try the latest beta:

    http://www.arnebrachhold.de/redir/sitemap-dl-beta/

    If upgrading doesn't solve your problem, try to raise the memory limit (see "Advanced options" at the plugin configuration page).

  4. rwosborn
    Member
    Posted 6 years ago #

    Hey, I downloaded the plugin and ran it, but it didn't seem to complete, as it was taking too long. Now when I go to the settings page and click on the XML Sitemap admin page, it shows the message below in red:

    The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts.

    How do I rerun it from that page? I'm not real good with monkeying with code and such. Is there a way to rerun it again? What are your suggestions? How long should it take to actually generate the sitemap. My site doesn't have that much content yet. Thanks for your help!

  5. rwosborn
    Member
    Posted 6 years ago #

    Hoping someone still has an idea how to direct me on this.

  6. rwosborn
    Member
    Posted 6 years ago #

    Again, any ideas guys?

  7. arnee
    Member
    Posted 6 years ago #

    Hi,

    could you try if the new version (released a few minutes ago) fixes your problem? If not, open the configuration page, go to the "Advanced options" and enter "64M" in the field "Try to increase the memory limit to". Save the options and click on "rebuild the sitemap" at the status panel.

    How long the plugin needs to build your sitemap mostly depends on the size of your blog and the power of your webserver, so it's hard to tell without more information...

  8. rwosborn
    Member
    Posted 6 years ago #

    arnee,

    Thanks buddy - you're a genious. Wow! That was fast and easy. Worked like a charm! Keep up the good work!

  9. arnee
    Member
    Posted 6 years ago #

    I'm glad it's working for you now! Did the new version solve your problem or did you increase the memory limit by hand?

  10. rwosborn
    Member
    Posted 6 years ago #

    I upgraded to the new version and also increased the memory, but I had tried that before and it didn't work. This time it worked right away.

Topic Closed

This topic has been closed to new replies.

About this Topic