WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
Early testers wanted (200 posts)

  1. Wiki Chaves
    Member
    Posted 3 years ago #

    Hi Sterling,

    If you fork the project would be Very usefull to include CPT support.

    Best,
    Wiki

  2. JonoAlderson
    Member
    Posted 3 years ago #

    Hi Sterling,

    Certainly: http://www.daysoftheyear.com/sitemap.xml

    I'm also using the GUAR Google XML Sitemaps plugin to add support for custom post types; I suspect that this may be where the problem lies?

    Might be an easy fix if so!

  3. johnnyone
    Member
    Posted 3 years ago #

    having same issues as JonoAlderson - would be good to figure it out

  4. Sterling Hamilton
    Member
    Posted 3 years ago #

    JonoAlderson: I'm unable to find any 404 sitemaps.

    Any more specifics? If I can see it - I can fix it.

  5. JonoAlderson
    Member
    Posted 3 years ago #

    Hi Sterling,

    Any of the child sitemaps of http://www.daysoftheyear.com/sitemap.xml (e.g., http://www.daysoftheyear.com/sitemap-misc.xml) return a 404 header status :(

  6. Wiki Chaves
    Member
    Posted 3 years ago #

    that's because you are including a ) in the URL !!

    try http://www.daysoftheyear.com/sitemap-misc.xml

  7. JonoAlderson
    Member
    Posted 3 years ago #

    Sorry, the bracket's a typo on my part.

    Let me clarify - loading/accessing the sitemap and its children works fine. However, any child sitemaps return a 404 HTTP header status, even though the page displays correctly...

  8. the red bicycle
    Member
    Posted 2 years ago #

    And Im just happy that the beta version is stable enough to index my site, even though I dont have permalinks.

    Good job Arne!

  9. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    Hi guys,

    sorry for not replying. I was abroad for studying and writing my diploma, so there was not really much time to do anything.

    I will have a look at the problems you're experiencing now!

    Custom Post Type support is also definitely on the todo-list, but first I want to fix these 404s which some of you getting.

    Thanks,

    Arne

  10. Nadiamode
    Member
    Posted 2 years ago #

    4.0b3 beta doesn't work with custom post type --- it work only with default wordpress post format = (gallery + aside), my custom post type example. movie, video not work ..

  11. TussendoorHQ
    Member
    Posted 2 years ago #

    Updated to 4.0b4 gives me the follow xml error

    This page contains the following errors:

    error on line 2 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

  12. cozmic_
    Member
    Posted 2 years ago #

    My site has over 300000 tags and sitemap-tax-post_tag.xml does not work with this huge count of tags. i get this Error: no element found in sitemap-tax-post_tag.xml row:4, column:236

    i increased both memory and execution time but the result is same. Any suggestion?

  13. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    please try the newest beta including support for custom post types!

    http://www.arnebrachhold.de/redir/sitemap-dl-beta/

    Thanks,

    Arne

  14. M
    Member
    Posted 2 years ago #

    Hi,

    I've just updated to the latest version of the beta plugin hoping it would solve the issue I had with the sitemap-tax-post_tag.xml.

    Unfortunately, it didn't. I still get this error:
    XML Parsing Error: no element found
    Location: http://www.mediasinfo.ro/sitemap-tax-post_tag.xml
    Line Number 11, Column 57:

    What do you think might be the issue?
    Many thanks.

  15. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    Do you actually have any tags for your posts?

  16. M
    Member
    Posted 2 years ago #

    Yes :) About 33.000 tags in total.

  17. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    Mhhh 33.000 tags... thats a lot. I guess that PHP just runs into the memory limit. The tags are not split at the moment, so it might be simply to much.... Did you try to raise the memory / time limit and could you have a look in the apache log file if you see any memory error message?

  18. M
    Member
    Posted 2 years ago #

    I have already increased the limit to 68MB as I was having issues with the old version of WP+Google Sitemaps + WP SEO+W3TC.

    I haven't checked the apache logs yet, but thanks for the tip. I will do so and come back with info.

  19. M
    Member
    Posted 2 years ago #

    Hello again. I just checked with the HG tech support and there aren't any errors that might show PHP runs out of memory. Any idea where it might come from though?

    Thank you.

  20. astpaul
    Member
    Posted 2 years ago #

    Hi

    I have an incompatibility with the latest beta (4.05) and WP Super Cache 0.9.9

    There is no output when clicking on http://voltigers.com/tapuat/sitemap.xml

    WordPress is multisite enabled and on 3.1.2

    can someone help?

  21. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    @M: Please try the following:

    1. Open sitemap-core.php
    2. Go to line 1488 (public function ShowSitemap($options) {)
    3. Insert below:

    error_reporting(E_ALL);
    ini_set("display_errors",1);

    4. Try to open the tags sitemap and check if you see any error (also try to look in the HTML source)

    @astpaul: Somehow the WP Super Cache plugin changes the URL of the XSLT stylesheet to your CDN. Try to disable the Stylesheet by unchecking the "Use default" next to "Include a XSLT stylesheet" on the admin screen.

  22. pushhyarag2000
    Member
    Posted 2 years ago #

    Hi,

    This is from a code-illiterate blog guy. Blog is Evolve-Forever

    I've used the plugin and get no errors-just working fine, it looks. But a silly question: I saw on some blog [phew, can't remember nor can locate that via history] there is a page in the navigation menu which when clicked shows the sitemap [as you show by illustration link on your plugin page. Can I get instructions for doing that anywhere?

  23. Aahan Krish
    Member
    Posted 2 years ago #

    @Arne Hi. Is the latest beta (v4.05b) without issues for normal blogs yet? (By normal blogs I meant, single WordPress installation - - i.e., NOT WordPress MU etc)

    Also, because it's dynamically generated sitemap, will Google Webmaster tools throw me an error saying it gets a 404 Error message when trying to pull the sitemap?

    Is everything almost fine? I would like to know, before I install beta.

  24. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    @pushhyarag2000: There is no link, but you can view your sitemap ere: http://www.evolve-forever.com/sitemap.xml

    @Aahan: It also works for "normal" installations. Just try it out, if it doesn't work for some odd reason, you can still just install the old version again.

  25. pushhyarag2000
    Member
    Posted 2 years ago #

    Hi Arne,

    Yes, I can view my sitemap with that link. My question is: can I create a page on my blog to show the sitemap [human readable]? And if yes, how?

    Thanks.

  26. pushhyarag2000
    Member
    Posted 2 years ago #

    Resolved. Silly mistake in url entry-I had put in an extra [.]. The page is working on my blog.

  27. rmvalues
    Member
    Posted 2 years ago #

    I got this error

    This page contains the following errors:

    error on line 1 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

    how to fix it ?

    thank you

  28. Arnee
    Member
    Plugin Author

    Posted 2 years ago #

    Can you provide the URL to your sitemap so I can have a look? Thanks!

  29. Neflite
    Member
    Posted 2 years ago #

    Hi Arne,
    just installed your newest BETA, because of problems with the last final version when submitting it to Bing & Yahoo (Google & ASK) worked.(Uninstalled the old and removed sitemap.xml & gz

    So it seems to work....http://www.openandfree.de/sitemap.xml work.
    But in the Sitemap Options it says "Search Engines haven't been notified yet"....

    How can i ensure it's completeley working for alle search engines?

  30. Neflite
    Member
    Posted 2 years ago #

    O.k., Update:
    Suddenly it stopped, without that i have changed something...now i get a 404 too.... :-(

    Update 2:

    Crazy...it seems it's working on some computers i have, and for others it doesn't....

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic