WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Doesn't Work in 2.9 (33 posts)

  1. Tranny
    Member
    Posted 4 years ago #

    XML Sitemap doesn't automatically rebuild and notify search engines since upgrade to 2.9

    I have four blogs, each I have upgraded to 2.9 on a different day and each had last rebuild on that day. After upgrade, despite new posts made, the plugin no longer works automatically. You can rebuild it manually, but that's white. Is this going to get fixed soon?

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. arnee
    Member
    Posted 4 years ago #

    Hi,

    Thats unfortunately a bug in WordPress 2.9. Basically, the cron system which should build the sitemap in the background is broken.

    As a workaround until WP 2.9.1 is released (which will be VERY soon), you can disable the option to build the sitemap in a background process. Note that this will cause some delay after hitting the publish button.

  3. Sierra81
    Member
    Posted 4 years ago #

    It doesn't work in 2.9.1 either. I have to rebuild it manually. I tried everything I could to fix this and it still doesn't work.

  4. montyloree
    Member
    Posted 4 years ago #

    I installed your xml sitemap.. and it's not validating on feedvalidator...
    http://stockinvesting-montyloree.com/sitemap.xml WP 2.9.1

    It's also not validating in twitterfeed.com

    It looks fine in the browswer though

    What do I need to do..

  5. macsters
    Member
    Posted 4 years ago #

    Hi, I have the same problem. I have now upgraded to 2.9.1 but the sitemap still doesn't update. When I try the "rebuild the sitemap" manually it says that it was generated but the actual sitemap does not change and the latest posts are still not added. I also get an error message when it tries to notify Ask.com. saying that it times out at line 2364 of the sitemap-core.php file. I checked that line and it is a blank line. I would really appreciate any insight on how to fix these issues. Thank you.

  6. talyal
    Member
    Posted 4 years ago #

    still not working with 2.9.1. - any updates for this? any other plugins someone can suggest?

  7. Vilmis
    Member
    Posted 4 years ago #

    Just upgraded to 2.9.1 and it is not working either. What is best alternative would be?

  8. powpowsincow
    Member
    Posted 4 years ago #

    Can anyone please help me. these are the error mesage i keep on getting...

    # There was a problem writing your sitemap file. Make sure the file exists and is writable.

    # There was a problem writing your zipped sitemap file. Make sure the file exists and is writable.

    But my root and all files are writable! I have tripled check... even with my hosting provider (Goddady)

    thanks

  9. macsters
    Member
    Posted 4 years ago #

    I got my sitemap working. I don't know if this will help anyone else but after trying so many things and couldn't get it to produce the new rebuild I decided to clear my cache and start again. Once I cleared my cache I went to view the xml sitemap and sure enough a new one with all my posts from the last 3 weeks was there. I'm not sure why that made the difference but possibly something in my cache was blocking the new rebuilds from showing. Possibly this may help someone else.

  10. Joe.Barreca@gmail.com
    Member
    Posted 4 years ago #

    I have XML Sitemap installed and it is updating the sitemap files, but I cannot get to the configuration page which links from the dashboard as:

    http://panoramagem.com/wp-admin/options-general.php?page=google-sitemap-generator/sitemap.php
    The error is:

    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    Is this a permissions problem in the google-sitemap-generator directory? or something else?

  11. iceman2008
    Member
    Posted 4 years ago #

    @macsters

    Do you mean clear the cache in your browser or on your server?

    How do you clear cache in your server?

    By the way I have the same problem. My posts are not being updated.

  12. macsters
    Member
    Posted 4 years ago #

    @iceman2008

    I just cleared the cache in my browser and then typed http://www.mysite.com/sitemap.xml and all my updates were there, and it has continued to work properly since. I think it must have been a gliche in the upgrade to 2.9 and 2.9.1 and clearing the cache just seemed to allow it to start functioning properly again.
    Good luck.

  13. iceman2008
    Member
    Posted 4 years ago #

    @macsters

    For someone reason or another, clearing the cache of the browser does not resolve this issue for me.

    I guess the developer (Arne Brachhold) of this plugin is not also monitoring this forum. I have no option left but to look for another plugin.

    Thanks for your help though.

  14. talyal
    Member
    Posted 4 years ago #

    i had the same problem and clearing the cache worked, but the feed still does not validate???

    Any solutions? or any other plugins someone can refer?

  15. Miklos
    Member
    Posted 4 years ago #

    For me (with 2.9.1) it does not work, manual update returns error 500. The file is not created.

  16. Hooper
    Member
    Posted 4 years ago #

    This plugin has had many issues since the upgrade.
    Getting errors like this that contradict... we have increased script memory to 64M and the file size is 25.25 mb but still errors. Hopefully Arnee checks this out as it is a bug.

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 25.25MB, the limit of your server is 64M.
    # The last known execution time of the script was 0.05 seconds, the limit of your server is 120 seconds.
    # The script stopped around post number 45 (+/- 100)

  17. qwertyboy999
    Member
    Posted 4 years ago #

    can anyone help please i have installed site map generator and i keep getting these codes
    There was a problem writing your sitemap file. Make sure the file exists and is writeable.
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writeable.

    well i think i have created the files and uploaded the correctly and changed the permissions to 666 on both but i keep getting this i have uninstalled it and installed it to see if that makes a difference please help anyone

  18. duckonwater
    Member
    Posted 4 years ago #

    We have many sites running WP 2.9.1 and all have the same problem with the Sitemap plugin automatic refresh.

    Basically when it does an auto refresh after some edits to the site it completely wipes the sitemap only leaving the root url.

    The only way to avoid this is to switch off the auto feature and rebuild the sitemaps manually, following edits to the websites.

    I really hope that Arne Brachhold can fix this bug as its such a good plugin and has become a standard for many web developers.

  19. apcpub
    Member
    Posted 4 years ago #

    I don't seem to be having the rebuild problem with wp 2.9.1 and v3.2.2 of the plugin.

    I do have a problem with trying to exclude individual posts and pages that I don't want to be indexed by the search engines.

    Excluding entire categories does seem to work though.

  20. bharathvn
    Member
    Posted 4 years ago #

    Hi,

    I have around 24K post on my site and auto/manual build stops around 22k

    and sitemap fails to webmaster tools

    i used wordpress 2.9.2 and sitemap 3.2.2

    here is the error

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 30.75MB, the limit of your server is 512M.
    # The last known execution time of the script was 38.78 seconds, the limit of your server is 400 seconds.
    # The script stopped around post number 22724 (+/- 100)

    When i build manually after 22k pages, diverts to homepage of my site.

  21. bharathvn
    Member
    Posted 4 years ago #

    Hello

    Any updates?

    Any suggestion for using other XML sitemap Pls?

    Thanks

  22. webnme2
    Member
    Posted 4 years ago #

    I am also having the problem some have described; e.g.,

    # There was a problem writing your sitemap file. Make sure the file exists and is writable.

    # There was a problem writing your zipped sitemap file. Make sure the file exists and is writable.

    The files exist and the permissions were set according to the directions. Created the files, moved them to the blog's root and used FTP to chmod the files. File permissions showed properly and no dice.

    Decided to try Karailiev's Sitemap and see what happened. Same thing.

    The host server runs Windows with IIS, so I'm guessing the host is going to have fiddle with Windows File permissions to allow WordPress to own or write to the files. If that doesn't work, I'm out of ideas and could use some.

  23. webnme2
    Member
    Posted 4 years ago #

    For the last few days, I've tried to get this to work without success. Still get the errors about writing a sitemap file. Tried to uninstall and reinstall it, but that did not go well. I could eventually get it to uninstall, but after that I could not get it to reinstall correctly from the WP Admin console. Had to use ftp to load the files instead. I've also ask the host to look into it and see what can be done. So far no joy there either. Have installed other plug-ins like a backup plug-in that writes files and that works fine. Am starting to think that the coding of this plug-in and the other XML sitemap plug-in are written for specific types of installs and don't play well on WP where it is associated with a separate website and not here. If anyone knows of a good XML sitemap plug-in that works well out side of wordpress.com hosting, I'd love to hear about it.

  24. webnme2
    Member
    Posted 4 years ago #

    I was finally able to get this to work. The path was the problem. I had to run the debugger to find out the path it wanted. The automatically discovered path was no good and trying to guess a custom path did not work well. Once I put in the correct path, it ran.

  25. Stingraynut
    Member
    Posted 4 years ago #

    hey webnme2, if I do a clean install of Google XMl sitemaps, will that work OK?

    Is it just the preinstalled plugin that stops workin with the wordprss update?

  26. arboundy
    Member
    Posted 4 years ago #

  27. algen
    Member
    Posted 4 years ago #

    Hello,

    Here's the problem that I encounter with the plugin. I installed Google XMl sitemaps 3.2.3 on my site which is WP 2.9.2. It was successfully installed but the problem was that, when I went to the control panel of the plugin, nothing was there! The page was empty! No options, no text, no boxes, etc.

    Is this problem a result on plugins that are not compatible with each other? What I mean is that, is there a plugin the should not be installed together with Google XML sitemaps generator because they conflict at some point?

    Does anyone have this problem too?

    Algen

  28. kevin_noall@hotmail.com
    Member
    Posted 4 years ago #

    I'm having the same problem with the UI only showing a blank page. Its interesting as I have it on another site under the same versions etc and it works there.

  29. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all other plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - increasing your available memory?

  30. kevin_noall@hotmail.com
    Member
    Posted 4 years ago #

    I did find an incompatible plugin. For me it was WordPress Automatic Upgrade. Once deactivated Google XML Sitemap works

Topic Closed

This topic has been closed to new replies.

About this Topic