WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
404 error on sitemap page and Google Red "X" (6 posts)

  1. WhatBoundariesTravel
    Member
    Posted 3 years ago #

    I tried to search and did not easily find this error. I used the plugin to generate a sitemap but it does not seem to be recognized. I tried to reset settings and regenerate a map as suggested in other entries.

    GOOGLE gave me this error when I submitted my URL:
    General HTTP error: 404 not found
    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

    My site map was generated and given the following URL: http://www.whatboundariestravel.com/blog/sitemap.xml
    Thanks for the help!

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. artur
    Member
    Posted 3 years ago #

    i have the same issue.
    please help..time sensitive.. thanks

  3. WhatBoundariesTravel
    Member
    Posted 3 years ago #

    Hello Artur-
    I never received a reply, but played around for hours and finally figured it out.. At the plugin settings under "Location of your Sitemap File I had to set it up as custom location and removed the www.

    My sitemap was recognized at Google as whatboundariestravel.com/sitemap.xml, but the plugin was creating it at http://www.whatboundariestravel.com/sitemap.xml. When I set it up as custom and removed the www, it worked.

    Good luck

  4. webjunk
    Member
    Posted 3 years ago #

  5. sahaskatta
    Member
    Posted 3 years ago #

    @webjunk,

    I was having a similar issue with the plugin. So I upgraded to the latest 4.0beta3. It looks as though I'm still getting an X in Webmaster Tools. It simply says that my sitemap wasn't the right format:

    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

    I felt it was the www vs. non-www issue. But in the new version, the sitemap is generated dynamically, so I have no control on tweaking the URL. I also noticed that my server was serving it from http://skattertech.com/sitemap.xml but not from http://www.skattertech.com/sitemap.xml

    I decided to add a .htaccess no-www rule to 301 redirect everything to the no-www version. Now both of the URLS above work. I'm running Webmaster Tools again. Hopefully it will work this time around.

    Let me know if I can be of any help. Or if you have any suggestions.

  6. sahaskatta
    Member
    Posted 3 years ago #

    Sorry for the double update, but unfortunately the sitemap check failed with Google. The error message is the same as what I quoted above.

    This plugin used to work perfectly in the past. However it stopped working about a month or so ago.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic