WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemap for Videos
How Does the Plugin Recognize the Youtube Video? (7 posts)

  1. mcovington3
    Member
    Posted 4 years ago #

    In other words, what is the optimal way for the plugin to recognize the youtube video on the site? Right now I post youtube via a shortcode plugin and I dont think it recognizes it. Something like [youtube]...[/youtube]

    http://wordpress.org/extend/plugins/xml-sitemaps-for-videos/

  2. Amit Agarwal
    Member
    Plugin Author

    Posted 4 years ago #

    The plugin currently scans for youtube URLs in a blog post. So if you have placed the YouTube url inside [tagname]..[/tagname], the plugin should pick up your videos.

  3. K4TAY
    Member
    Posted 3 years ago #

    My video are also embeded using custom fields and your plugin is not catching them. Also, if the wordpress installation is not at the root, the sitemap is created at the root and the link from the success page points to the root of the wordpress installation.

    Good work. Just a few tweeks and you got it!

  4. cstina
    Member
    Posted 3 years ago #

    @labnol

    Can you explain what you mean by [tagname]..[/tagname] ?

    I've never even seen an option to wrap youtube code in tagname tags.

    Step by step what you mean??

    Thanks

  5. Amit Agarwal
    Member
    Plugin Author

    Posted 3 years ago #

    @cstina - Some YouTube related WordPress plugins using the []..[/] shortcode format. If you have never seen this, chances are that you are not using such a plugin on your blog.

  6. Douglas Karr
    Member
    Posted 3 years ago #

    It would be great if this supported other video hosting sites, such as Vimeo, too.

  7. apcpub
    Member
    Posted 3 years ago #

    This plugin is great. Just what web masters need!

    YouTube recently started supporting an iframe embed code and I recently started using it so my videos are all compatible with iPhone / iPad and other HTML 5 video.

    Despite <iframe> </iframe> tag having a YouTube link in it this plugin isn't seeing them :(

    Please update! Also, I second K4TAY in putting the file in the right place if your blog is hosted in a sub-folder (not root).

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic